Thread: MySQL problem
View Single Post
  #1  
Old 14th February 2013, 14:43
dimas dimas is offline
Senior Member
 
Join Date: Jul 2006
Posts: 125
Thanks: 7
Thanked 27 Times in 8 Posts
Default MySQL problem

Hello everybody, I have a big problem on a production server (ISPConfig 3.0.4.6, Debian Squeeze 64-bit, Perfect Setup)

I noticed that I can't create new mysql databases via ISPConfig interface. A line with a new database actually appears, but no new database is actually created - and there's nothing new in /var/lib/mysql

I tried to log in as mysql root user via shell - and there was another nasty surprise - it said access denied (wrong credentials)!

So something - or someone - changed my root mysql password.

I still CAN login as other regular mysql users.

I tried to reset the root user password by using this howto:

http://www.howtoforge.com/reset-forg...-root-password

but this line

mysqld_safe --skip-grant-tables

doesn't start mysql, it just hangs...

So - was the server hacked, or something just went wrong?

Is there a way to somehow revive the server?

I'd welcome any advice!
Reply With Quote
Sponsored Links