View Single Post
  #1  
Old 25th January 2013, 20:48
kendel kendel is offline
HowtoForge Supporter
 
Join Date: Aug 2010
Posts: 132
Thanks: 4
Thanked 1 Time in 1 Post
Default ReverseProxy Redirect "HTTPS" howto?

I got the subdomain ReverseProxy to work on port 80.
Panel server config:
Code:
<VirtualHost *:80>
DocumentRoot /var/www/ispconfig
ServerName cp.example.com
ServerAlias cp.example.com
<Directory "/var/www/ispconfig">
allow from all
Options +Indexes
</Directory>
</VirtualHost>
Webserver config
Code:
<VirtualHost *:80>
ServerName cp.example.com
ServerAlias cp.example.com
ProxyRequests Off
ProxyPreserveHost on
ProxyPass / http://192.168.10.150/
ProxyPassReverse / http://192.168.10.150/
</VirtualHost>
This works perfectly fine, I would like to do an "HTTPS" version and made a 5th grader attemp. First I made a copy of the default ispconfig conf file on the panel server and called it scp.example.com and I changed the listen port to 443:
Panel Server default Ispconfig (made a copy):
Code:
NameVirtualHost *:443

<VirtualHost _default_:443>
  ServerAdmin webmaster@localhost

  <IfModule mod_fcgid.c>
DocumentRoot /usr/local/ispconfig/interface/web/
    SuexecUserGroup ispconfig ispconfig
    <Directory /var/www/ispconfig/>
      Options Indexes FollowSymLinks MultiViews +ExecCGI
      AllowOverride AuthConfig Indexes Limit Options FileInfo
      AddHandler fcgid-script .php
      FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
      Order allow,deny
      Allow from all
    </Directory>
...........................................................
Ok theres alot more in that file that what I just showed, but lets cut it short....
Now I created the Reverse Proxy on the webserver... (assuming default port for "HTTPS" is 443
The Web server:
Code:
<VirtualHost *:443>
RequestHeader set X-Forwarded-Proto "https"
    ProxyPreserveHost On
ServerName scp.example.com
ProxyRequests Off
ProxyPreserveHost on
ProxyPass / http://192.168.10.150:443/
ProxyPassReverse / http://192.168.10.150:443/
</VirtualHost>

Doesn't work at all...What am I missing?
__________________
If you are looking for examples of an ISPConfig 3 Multiserver Setup, Visit my website Here!!!

Last edited by kendel; 26th January 2013 at 06:23.
Reply With Quote
Sponsored Links