View Single Post
  #6  
Old 21st January 2013, 13:30
jconstantino jconstantino is offline
Junior Member
 
Join Date: Feb 2011
Posts: 4
Thanks: 0
Thanked 1 Time in 1 Post
Default My solution

Hi,

I've manage to use Nagios3 with ISPConfig2...I think that this is not a "clean and beautiful" solution, but maybe you can give it a try (replace webXXXX with your virtual server folder):

copy nagios3 cgi to /var/www/webXXX/cgi-bin/nagios3

in nagios3.conf I have:

ScriptAlias /cgi-bin/nagios3 /var/www/webXXX/cgi-bin/nagios3
ScriptAlias /nagios3/cgi-bin /var/www/webXXX/cgi-bin/nagios3

and

<DirectoryMatch (/usr/share/nagios3/htdocs|/var/www/webXXX/cgi-bin/nagios3|/etc/nagios3/stylesheets)>
Options FollowSymLinks +ExecCGI
DirectoryIndex index.php
AddHandler cgi-script .cgi .pl
AllowOverride AuthConfig
Order Allow,Deny
Allow From All

AuthName "blablabla..."
AuthType Basic
AuthUserFile /etc/nagios3/<file users>

require valid-user
</DirectoryMatch>

Hope this can help...

Regards,
Joao Constantino
Reply With Quote