View Single Post
  #1  
Old 18th January 2013, 06:58
nenad nenad is offline
Senior Member
 
Join Date: Nov 2005
Location: Novi Sad, Serbia
Posts: 416
Thanks: 13
Thanked 5 Times in 5 Posts
Default HELP PLEASE - Debian Lenny with ISPConfig upgrade to PHP 5.3 went wrong.

Hello to everyone,

I tried to upgrade PHP 5.2 to 5.3 on Debian Lenny - installed according perfect install with ISPConfig3. It worked fine for almost one year when I got the idea (because I need it because of one project) to upgrade PHP to 5.3

I thought it would be easy because of this
http://www.onigoetz.ch/2010/10/03/up...-debian-lenny/

or this

http://www.web2works.co.uk/blog2work...-debian-lenny/

But it didn't happen so.

Now it looks like I am totally without PHP.

Code:
piks:~# php -v
-bash: php: command not found
http://ftniim.org:8080/

gives internal server error.

I don't know what happened but I guess that "upgrade" broke some configuration files made by ISPConfig?

If that's of any help I have (at least) backup of /etc/mysql/my.cnf" , because during dist-upgrade it looks like database is upgraded too.

What should I do to make system work again?

When I try apt-get upgrade I got this:

Code:
piks:~# apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages have been kept back:
  mysql-client mysql-server php5-dev
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
piks:~#
Sources list is:

Code:
#
# deb cdrom:[Debian GNU/Linux 5.0.9 _Lenny_ - Official i386 NETINST Binary-1 20111002-08:57]/ lenny main

#deb cdrom:[Debian GNU/Linux 5.0.9 _Lenny_ - Official i386 NETINST Binary-1 20111002-08:57]/ lenny main

#deb http://ftp.us.debian.org/debian/ lenny main
#deb-src http://ftp.us.debian.org/debian/ lenny main

#deb http://security.debian.org/ lenny/updates main
#deb-src http://security.debian.org/ lenny/updates main

#deb http://volatile.debian.org/debian-volatile lenny/volatile main
#deb-src http://volatile.debian.org/debian-volatile lenny/volatile main
#deb http://volatile.debian.org/debian-volatile lenny/volatile main contrib non-free

deb http://archive.debian.org/debian/ lenny main contrib
deb-src http://archive.debian.org/debian/ lenny main contrib
#deb http://security.debian.org/ lenny/updates main contrib
#deb-src http://security.debian.org/ lenny/updates main contrib
deb http://archive.debian.org/debian-volatile lenny/volatile main
deb-src http://archive.debian.org/debian-volatile lenny/volatile main contrib non-free
deb http://php53.dotdeb.org stable all
deb-src http://php53.dotdeb.org stable all


P.S. I can't upgrade to Lenny to Squeeze because machine is too old. That's why I am using Lenny in the first place.
__________________
Nenad Bulatovic
---------------
Debian Lenny & ISPConfig 3

Last edited by nenad; 18th January 2013 at 07:23.
Reply With Quote
Sponsored Links