View Single Post
  #3  
Old 3rd January 2013, 16:49
DaRKNeSS666NL DaRKNeSS666NL is offline
HowtoForge Supporter
 
Join Date: Nov 2006
Posts: 207
Thanks: 17
Thanked 3 Times in 3 Posts
Default

Quote:
Originally Posted by quest View Post
My above post was nearly correct - but I was trying to use only one external IP address mapped to several unique internal IP addresses.

I'm not sure if this is possible.

My work around included assigning additional External IP addresses to each internal IP address that requires an SSL certificate. In this case I attached an additional external IP address to the internal IP address 10.0.0.110.

It is important to note that you use internal ip addresses to initiate the website and ssl certificate in Ispconfig and an External IP address for DNS purposes.
I am working on putting 2 extra IPv4 up for use with 2 websites that need SSL I have configured these 2 in network interfaces like this:

Code:
| # The primary network interface
 #allow-hotplug eth0
 #iface eth0 inet dhcp
 auto eth0
 iface eth0 inet static
         address xx.xxx.244.62
         netmask 255.255.255.0
         network xx.xxx.244.0
         broadcast xx.xxx.244.255
         gateway xx.xxx.244.254
 
 auto eth0:0
 iface eth0:0 inet static
         address xx.xxx.242.174
         netmask 255.255.255.255
         network xx.xxx.242.0
         broadcast xx.xxx.242.255
         gateway xx.xxx.242.254
 
 auto eth0:1
 iface eth0:1 inet static
         address xx.xxx.242.175
         netmask 255.255.255.255
         network xx.xxx.242.0
         broadcast xx.xxx.242.255
         gateway xx.xxx.242.254
And added them in the server settings if I restart the netwerk interface

Code:
server1:~# /etc/init.d/networking restart
Reconfiguring network interfaces...if-up.d/mountnfs[eth0]: waiting for interface eth0:0 before doing NFS mounts (warning).
if-up.d/mountnfs[eth0]: waiting for interface eth0:1 before doing NFS mounts (warning).
SIOCADDRT: No such process
Failed to bring up eth0:0.
SIOCADDRT: No such process
Failed to bring up eth0:1.
done.
server1:~#
As you can see the 2 ip's don't work, could it be that I must use also 2 internal ip for eth0:1 and eth0:0 and point the 2 external to those 2 internal?
But there is not mention about this in the manual so I don't know how to do it.

Also the data ceter has mentioned to use the loopback interface instead but as mentioned in the manual were not supposed to use this lines??
TIA
__________________
Updating my server to Debian Squeeze, so here I go again...
Reply With Quote