View Single Post
  #1  
Old 26th December 2012, 17:40
garson garson is offline
Junior Member
 
Join Date: Nov 2012
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default Postfixadmin + vacation, not working

Hi.
I have Ubuntu 11.04, postfix, dovecot, postfixadmin, and 3 webmails, Horde, Squirrelmail and Roundcube.
Everything is working as expected, but few days ago I have added vacation to postfixadmin.
I was setting it up according to this How to.
http://postfixmail.com/blog/index.ph...-postfixadmin/

So, when I try to send email from user1@mydomain.com to user2@mydomain.com which has vacation enabled, user1 doesn't get any email. Nothing happens.

This is what I get in /var/log/mail.log

Quote:
Dec 26 17:13:15 mail-server postfix/smtpd[2923]: connect from localhost[127.0.0.1]
Dec 26 17:13:15 mail-server postfix/smtpd[2923]: 494E746BEB: client=localhost[127.0.0.1], sasl_method=LOGIN, sasl_username=user1@mydomain.com
Dec 26 17:13:15 mail-server postfix/cleanup[2928]: 494E746BEB: message-id=<a2582d1884b6e3d4811bce510ab94c91.squirrel@192. 168.100.30>
Dec 26 17:13:15 mail-server postfix/qmgr[10573]: 494E746BEB: from=<user1@mydomain.com>, size=748, nrcpt=2 (queue active)
Dec 26 17:13:15 mail-server postfix/smtpd[2923]: disconnect from localhost[127.0.0.1]
Dec 26 17:13:18 mail-server postfix/smtpd[2944]: connect from localhost[127.0.0.1]
Dec 26 17:13:18 mail-server postfix/smtpd[2944]: 1BDE946B74: client=localhost[127.0.0.1]
Dec 26 17:13:18 mail-server postfix/cleanup[2928]: 1BDE946B74: message-id=<a2582d1884b6e3d4811bce510ab94c91.squirrel@192. 168.100.30>
Dec 26 17:13:18 mail-server postfix/qmgr[10573]: 1BDE946B74: from=<user1@mydomain.com>, size=1160, nrcpt=2 (queue active)
Dec 26 17:13:18 mail-server amavis[26797]: (26797-04) Passed CLEAN, LOCAL [127.0.0.1] [127.0.0.1] <user1@mydomain.com> -> <user2#mydomain.com@autoreply.mydomain.com>,<user2 @mydomain.com>, Message-ID: <a2582d1884b6e3d4811bce510ab94c91.squirrel@192.168 .100.30>, mail_id: IrgryC5kaQF1, Hits: -1, size: 748, queued_as: 1BDE946B74, 2766 ms
Dec 26 17:13:18 mail-server postfix/smtpd[2944]: disconnect from localhost[127.0.0.1]
Dec 26 17:13:18 mail-server postfix/smtp[2929]: 494E746BEB: to=<user2#mydomain.com@autoreply.mydomain.com>, orig_to=<user2@mydomain.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=2.8, delays=0.04/0.02/0.01/2.8, dsn=2.0.0, status=sent (250 2.0.0 from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 1BDE946B74)
Dec 26 17:13:18 mail-server postfix/smtp[2929]: 494E746BEB: to=<user2@mydomain.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=2.8, delays=0.04/0.02/0.01/2.8, dsn=2.0.0, status=sent (250 2.0.0 from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 1BDE946B74)
Dec 26 17:13:18 mail-server postfix/qmgr[10573]: 494E746BEB: removed
Dec 26 17:13:18 mail-server postfix/pipe[2946]: 1BDE946B74: to=<user2@mydomain.com>, relay=dovecot, delay=0.04, delays=0.01/0.01/0/0.02, dsn=2.0.0, status=sent (delivered via dovecot service)
Dec 26 17:13:18 mail-server postfix/pipe[2945]: 1BDE946B74: to=<user2#mydomain.com@autoreply.mydomain.com>, relay=vacation, delay=0.15, delays=0.01/0.01/0/0.13, dsn=2.0.0, status=sent (delivered via vacation service)
Dec 26 17:13:18 mail-server postfix/qmgr[10573]: 1BDE946B74: removed

And this is from /var/log/vacation.log
Quote:
2012/12/26 17:13:18 DEBUG> /var/spool/vacation/vacation.pl:560 main:: - Script argument SMTP recipient is : 'user2#mydomain.com@autoreply.mydomain.com' and smtp_sender : 'user1@mydomain.com'
2012/12/26 17:13:18 DEBUG> /var/spool/vacation/vacation.pl:590 main:: - Converted autoreply mailbox back to normal style - from user2#mydomain.com@autoreply.mydomain.com to user2@mydomain.com
2012/12/26 17:13:18 DEBUG> /var/spool/vacation/vacation.pl:600 main:: - Email headers have to: 'user2@mydomain.com' and From: 'user1@mydomain.com'
2012/12/26 17:13:18 DEBUG> /var/spool/vacation/vacation.pl:337 main::find_real_address - Found user2@mydomain.com has vacation active
2012/12/26 17:13:18 DEBUG> /var/spool/vacation/vacation.pl:626 main:: - Attempting to send vacation response for: <a2582d1884b6e3d4811bce510ab94c91.squirrel@192.168 .100.30> to: user1@mydomain.com, user2@mydomain.com, user2@mydomain.com (test_mode = 0)
2012/12/26 17:13:18 DEBUG> /var/spool/vacation/vacation.pl:428 main::send_vacation_email - Asked to send vacation reply to user2@mydomain.com thanks to <a2582d1884b6e3d4811bce510ab94c91.squirrel@192.168 .100.30>
2012/12/26 17:13:18 DEBUG> /var/spool/vacation/vacation.pl:436 main::send_vacation_email - Already notified user1@mydomain.com, or some error prevented us from doing so
/var/log/vacation.debug is empty.

Does anybody knows what could be the problem?

Thanks.
Reply With Quote
Sponsored Links