View Single Post
  #1  
Old 21st December 2012, 10:01
suntribe suntribe is offline
Junior Member
 
Join Date: Dec 2012
Location: Zagreb
Posts: 14
Thanks: 2
Thanked 1 Time in 1 Post
Cool Cannot access my virtualhosts from roundcube

As I'm new here let me say EHLO howtoforge.com

So, couple of days ago I purchased an unmanaged root server and since then I'm trying to make emails work. I have followed couple of different tutorials but none of them took me to the final destination. I'm starting to believe that now, maybe whats blocking me is some old settings from some tutorial I followed but I simply have no clue what to look for and where to look for the answer.

So, first let me give you some info what I have done (maybe this matters). Immidiatelly after i got my root credetials, I created a new user and gave him the sudo rights. Created cuple of new groups (neither of them interferre with those used in mail tutorials), and installed php, apache and mysql. I set up one website in apache and the last thing I did was changing the host name... That's about everything. Then i started with mail tutorials.

Last mail tutorial I followed (http://flurdy.com/docs/postfix/) gave me partial success. I can telnet to port 25 of the localhost, can send email, receivers receive email (no matter do I send the mail from localhost or from gmail!) so I guess that postfix + courier + virtual hosts saved in mysql work ok. I can see folders and files in /var/spool/mail/virtual/virtual_user_dir...

Then I tryed to install roundcube, and set it up, but when I try to enter my virtual user credentials, roundcube alerts me with error Connection to IMAP server failed.

I checked the logs: /var/log/auth.log and /var/log/mail.err give no error for this, but in /var/log/mail.log i found this: sunzone imapd-ssl: couriertls: /etc/ssl/certs/905b837e.0: No such file or directory.

I tryed to see does /etc/ssl/certs/905b837e.0 exists and i found a symlink to a real file (lrwxrwxrwx 1 root root 33 Dec 19 14:00 905b837e.0 -> /etc/mail/tls/sendmail-server.crt) but the real file doesn't exist! Even more in /etc/mail i have no /tls/ dir! I tryed to delete the symlink but, UBUNTU 12.04 is recreating it again with a new symlink name and the same destination.

I remember that in on tutorial i followed before the last one, I did create certificates name sendmail-server... but honestly, i can't remember wich one was it... I strongly believe that IMAP error that Roundcube gives me is related to this certfile error, but again, I'm not sure...

Please help me with this one - I'm rellay tired and sleepless for past three days trying to set this email up
Reply With Quote
Sponsored Links