View Single Post
  #3  
Old 27th November 2012, 12:58
kurdak kurdak is offline
Junior Member
 
Join Date: Nov 2012
Posts: 19
Thanks: 6
Thanked 0 Times in 0 Posts
Default

Okay, so I made so far these commands:
Code:
mkdir /opt/php-5.2.17
mkdir /usr/local/src/php5-build
cd /usr/local/src/php5-build
wget http://de.php.net/get/php-5.2.17.tar.bz2/from/this/mirror -O php-5.2.17.tar.bz2
tar jxf php-5.2.17.tar.bz2
cd php-5.2.17/
Now I need to configure PHP 5.2.17:
Code:
./configure \
--prefix=/opt/php-5.2.17 \
--enable-fastcgi \
--disable-rpath \    - If this setting is turned on I get the same extras as the main PHP?
--with-mysql
I made:
Code:
make
make install
cp /usr/local/src/php5-build/php-5.2.17/php.ini-recommended /opt/php-5.2.17/lib/php.ini
In ISPConfig setting Additional PHP Versions:
Additional PHP Versions: /opt/php-5.2.17/bin/php
Path to the php.ini directory: /opt/php-5.2.17/lib

And now if I go to the my sub.domian.com I get: ERROR 500 - Internal Server Error
Now what I have to do?

Last edited by kurdak; 29th November 2012 at 11:15.
Reply With Quote