View Single Post
  #15  
Old 20th November 2012, 16:11
babixeddu babixeddu is offline
Junior Member
 
Join Date: Nov 2012
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Hate this s...stuff

It's very frustrating read all, and at the end... ta tannn where the f*** is your problem? is gone? how did you have solved this problem? eh? eh? Hate this. Hate this.

I've the same problem. I've followed the same tutorial as is, and at the end I can't connect:

- auth.log
Code:
[...] pure-ftpd: pam_unix(pure-ftpd:auth): check pass; user unknown
[...] pure-ftpd: pam_unix(pure-ftpd:auth): authentication failure; logname= uid=0 euid=0 tty=pure-ftpd ruser=exampleuser rhost=dynamic-adsl[...]
- syslog
Code:
[...]  [ERROR] The SQL server seems to be down [Can't connect to local MySQL server through socket '*****/var/run/mysqld/mysqld.sock' (2)]
[...]  [INFO] PAM_RHOST enabled. Getting the peer address
[...]  [WARNING] Authentication failed for user [exampleuser]
[...]  [INFO] Logout.
- /etc/pure-ftpd/db/mysql.conf is the same (naturally I've changed the psw, which contains a special char, can be this?).

- Port 3306 it's closed to the world but the connection is made with the mysql.sock so it's irrelevant. 21 is - naturally - open.

Any thought?

Thanks

---- EDIT ----

It seems to be solved: the problem was on the folder permission and probably on the /etc/pure-ftpd/db/mysql.conf ... So:

1) when copying the code made by falko, it's better to double check if the pasted code is good.
2) I've created an "ftp" folder under /home (so: /home/ftp) and I've assigned the owner with chown root.ftpgroup -R to the ftp folder.
3) I've changed the mysql row:

INSERT INTO `ftpd` (`User`, `status`, `Password`, `Uid`, `Gid`, `Dir`, `ULBandwidth`, `DLBandwidth`, `comment`, `ipaccess`, `QuotaSize`, `QuotaFiles`) VALUES ('exampleuser', '1', MD5('secret'), '2001', '2001', '/home/ftp/www.example.com', '100', '100', '', '*', '50', '0');

- Now I got a timeout error but the user is logged in and the folder is created under /home/ftp.

---- EDIT 2 ----
The timeout error was generated when selecting "Passive mode" from Filezilla. Choosing "Active mode" solves the problem.

Hope it's useful, cheers!

Last edited by babixeddu; 20th November 2012 at 17:55. Reason: adding solution to timeout
Reply With Quote