View Single Post
  #2  
Old 19th November 2012, 15:18
pallermo pallermo is offline
Junior Member
 
Join Date: Feb 2010
Posts: 16
Thanks: 0
Thanked 6 Times in 5 Posts
Default

It can work only in this case:

Code:
# RoundCube alias and redirect functions
Alias /webmail /var/www/webmail
<Directory /var/www/webmail>
  Options +FollowSymLinks
  # This is needed to parse /var/www/webmail/.htaccess. See its
  # content before setting AllowOverride to None.
  AllowOverride All
  order allow,deny
  allow from all
</Directory>
# Protecting basic directories:
<Directory /var/www/webmail/config>
        Options -FollowSymLinks
        AllowOverride None
</Directory>
<Directory /var/www/webmail/temp>
        Options -FollowSymLinks
        AllowOverride None
        Order allow,deny
        Deny from all
</Directory>
<Directory /var/www/webmail/logs>
        Options -FollowSymLinks
        AllowOverride None
        Order allow,deny
        Deny from all
</Directory>
<IfModule mod_rewrite.c>
  <IfModule mod_ssl.c>
    <Location /webmail>
      RewriteEngine on
      RewriteCond %{HTTPS} !^on$ [NC]
      RewriteRule . https://www.domain.com:8080/webmail/  [L]
    </Location>
  </IfModule>
</IfModule>
If I remove mode_rewrite I get Error 500.
Damn
Reply With Quote