View Single Post
  #1  
Old 29th October 2012, 02:47
foxx foxx is offline
Junior Member
 
Join Date: Feb 2010
Posts: 5
Thanks: 1
Thanked 2 Times in 1 Post
Question Cronjob handling, webpage users shell doesn't change - Bug?

I'm very confused how user cronjobs are handled.

I've created a user which at first had only URL cron rights.
This worked quite well and all the URLs were executed as expected.

Than I added a new PATH cronjob as admin to this user. There wasn't any error and I haven't seen that this user should only be able to have URL crons.

This cron didn't worked as expected and I found the problem: The webpage users (webXX) shell was set to Jailkit but Jailkit wasn't configured properly:

Code:
abort, homedir '/var/www/clients/clientX/webXY' for user webXY (5008) does not contain the jail separator <jail>/./<home>
I decided to add the jail seperator manually and the cronjob started working - but only inside chrooted Jailkit (I haven't found any way to choose between Jailkit/Full execution as admin).

My aim was and is to get the cronjob work in the full environment - not chrooted.

So I changed the users Cron Type Limit to "Full Cron" - nothing changed.
Than I recreated the cronjob inside ISPConfig as the user - nothing changed.

The cronjob is still executed by the webpage UNIX User webXX and it's shell is still the jailkit shell.

This is very confusing. Is this the desired behaviour or should I fill a bug report.

Is there any way of changing the webpage users shell to the default bash/sh... with ISPConfig or do I have to do this manually?
Reply With Quote
Sponsored Links