View Single Post
  #7  
Old 23rd October 2012, 16:06
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,716 Times in 2,558 Posts
Default

Code:
location ~ \.php$ {
                # Setup var defaults
                set $no_cache "";

                # If non GET/HEAD, don't cache & mark user as uncacheable for 1 second via cookie
                if ($request_method !~ ^(GET|HEAD)$) {
                    set $no_cache "1";
                }

                # Drop no cache cookie if need be
                # (for some reason, add_header fails if included in prior if-block)
                if ($no_cache = "1") {
                    add_header Set-Cookie "_mcnc=1; Max-Age=2; Path=/";
                    add_header X-Microcachable "0";
                }

                # Bypass cache if no-cache cookie is set
                if ($http_cookie ~* "_mcnc") {
                            set $no_cache "1";
                }

                # Bypass cache if flag is set
                fastcgi_no_cache $no_cache;
                fastcgi_cache_bypass $no_cache;

                access_log /var/log/nginx/access.log cache;

fastcgi_cache microcache;
                fastcgi_cache_key $server_name|$request_uri;
                fastcgi_cache_valid 404 30m;
                fastcgi_cache_valid 200 10s;
                fastcgi_max_temp_file_size 1M;
                fastcgi_cache_use_stale updating;
                fastcgi_pass unix:/var/lib/php5-fpm/web11.sock;
                fastcgi_pass_header Set-Cookie;
                fastcgi_pass_header Cookie;
                fastcgi_ignore_headers Cache-Control Expires Set-Cookie;
                fastcgi_index index.php;
                fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
                fastcgi_split_path_info ^(.+\.php)(/.+)$;
                fastcgi_param  PATH_INFO          $fastcgi_path_info;
                fastcgi_param  PATH_TRANSLATED    $document_root$fastcgi_path_info;
                #try_files $uri =404;
                fastcgi_intercept_errors on;
                include /etc/nginx/fastcgi_params;

                }


        # unless the request is for a valid file, send to bootstrap
        if (!-e $request_filename)
        {
            rewrite ^(.+)$ /index.php?q=$1 last;
  }
This part is not the default ISPConfig PHP configuration. It looks like you have disabled PHP for the website and then added this section to the nginx Directives field, but with PHP disabled there's no PHP-FPM socket.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote