View Single Post
  #1  
Old 12th October 2012, 16:46
Wsbs9GC Wsbs9GC is offline
Member
 
Join Date: Aug 2012
Posts: 36
Thanks: 1
Thanked 0 Times in 0 Posts
Default Unable to connect to the database

Hello.
First, a bit about my setup:
I followed one of the perfect server guides and all processes are on the same machine.
The Problem:
After a system restart, my ispconfig 3 installation throws the errors:
  • Unable to connect to the database
  • Unable to connect to the database:
Notice the difference of the ending colon between the two. I have checked the information in /usr/local/ispconfig/server/lib/config.inc.php and /usr/local/ispconfig/server/lib/mysql_clientdb.conf as suggested in other threads and that information is correct. I have verified this by trying to log into mysql directly with mysql -u user -p and then pasting in the password in those files above. There are no errors in /var/log/mysql.err nor an entries in /var/log/mysql.log so it appears, at least to me, that a connection is never made to the mysql server. I then did some searching around and in /var/log/ispconfig/cron.log there is
Code:
Found linux image: /boot/vmlinuz-3.2.0-31-generic-pae
Found initrd image: /boot/initrd.img-3.2.0-31-generic-pae
Found linux image: /boot/vmlinuz-3.2.0-23-generic-pae
Found initrd image: /boot/initrd.img-3.2.0-23-generic-pae
Found memtest86+ image: /memtest86+.bin
done
PHP Warning:  mysql_connect(): Access denied for user 'root'@'localhost' (using password: NO) in /usr/local/ispconfig/server/plugins-available/mysql_clientdb_plugin.inc.php on line 276
PHP Warning:  mysql_error() expects parameter 1 to be resource, boolean given in /usr/local/ispconfig/server/plugins-available/mysql_clientdb_plugin.inc.php on line 278
PHP Warning:  mysql_connect(): Access denied for user 'root'@'localhost' (using password: NO) in /usr/local/ispconfig/server/plugins-available/mysql_clientdb_plugin.inc.php on line 133
PHP Warning:  mysql_error() expects parameter 1 to be resource, boolean given in /usr/local/ispconfig/server/plugins-available/mysql_clientdb_plugin.inc.php on line 135
Upon checking the file in question, I could not find any place within the file that sets the $clientdb_user and $clientdb_password variables.
What do I need to do to fix this problem and, if you wouldn't mind at least speculating, what caused this issue in the first place? All was working fine until a system restart.
Reply With Quote
Sponsored Links