View Single Post
  #7  
Old 10th October 2012, 04:04
destinedjagold destinedjagold is offline
Junior Member
 
Join Date: Aug 2012
Posts: 11
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko View Post
Your / directory is owned by the user apache and has 700 permissions which is wrong. For me it looks like this:

Code:
drwxr-xr-x 22 root  root      4096 Oct  8 17:00 ..
Did you do a chmod and chown on the / directory?
Thanks for the reply, and for your questions, yes, I think I did.
Should I return it to root? If so, what would be the proper code to use?

Thanks~

---edit---

Okay, so I used
Code:
chmod 755 /
and now it displays this...
Code:
total 354844
drwxrwxrwx.  8 root       root            4096 Oct 10 11:22 .
drwxr-xr-x.  28 root       root            4096 Oct 10 09:34 ..
Is this okay now?
I still cannot run MySQL...
Code:
MySQL Daemon failed to start.
Starting mysqld: [FAILED]
---edit 2---

Okay, I think I have fixed it. MySQL will now start when I type
Code:
service mysqld start
.
I think I should post here the things I did, for future reference?

The first thing I did was reinstall both mysql and mysql-server through yum.
And then, after reinstalling was done, I typed these following codes...
Code:
chown -R mysql.mysql /var/lib/mysql
Code:
su - mysql
I am not sure if those set of codes really fixed it, but those are the ones I used, and the MySQL Daemon error message is no longer appearing, and MySQL is starting with no problems.

Last edited by destinedjagold; 10th October 2012 at 11:08.
Reply With Quote