View Single Post
  #9  
Old 29th September 2012, 06:13
Tramis Tramis is offline
Junior Member
 
Join Date: Sep 2012
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi again!

I've just made a fresh installation following the Howto to the letter and i've got this:

Code:
Sep 29 04:59:08 mail postfix/submission/smtpd[19795]: connect from unknown[192.168.1.10]
Sep 29 04:59:08 mail postfix/submission/smtpd[19795]: NOQUEUE: reject: RCPT from unknown[192.168.1.10]: 550 5.1.1 <aaaa@wanadoo.fr>: Recipient address rejected: User unknown in virtual mailbox table; from=<bbbb@wanadoo.fr> to=<aaaa@wanadoo.fr> proto=ESMTP helo=<[192.168.1.10]>
Sep 29 04:59:09 mail postfix/submission/smtpd[19795]: disconnect from unknown[192.168.1.10]
wanadoo.fr : is my ISP declared as a domain in ISPconfig3.
aaaa@wanadoo.fr : is my wife's mailbox not handled (for now) by ISPConfig.
bbbb@wanadoo.fr : is my mailbox handled by ISPConfig3.

Here's my postconf -n:
Code:
root@mail:/tmp/ispconfig3_install/install# postconf -n
alias_database = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
alias_maps = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
append_dot_mydomain = no
biff = no
body_checks = regexp:/etc/postfix/body_checks
broken_sasl_auth_clients = yes
config_directory = /etc/postfix
content_filter = amavis:[127.0.0.1]:10024
dovecot_destination_recipient_limit = 1
header_checks = regexp:/etc/postfix/header_checks
html_directory = /usr/share/doc/postfix/html
inet_interfaces = all
mailbox_size_limit = 0
maildrop_destination_concurrency_limit = 1
maildrop_destination_recipient_limit = 1
message_size_limit = 0
mime_header_checks = regexp:/etc/postfix/mime_header_checks
mydestination = my.domain.com, localhost, localhost.localdomain
myhostname = my.domain.com
mynetworks = 127.0.0.0/8 [::1]/128
myorigin = /etc/mailname
nested_header_checks = regexp:/etc/postfix/nested_header_checks
owner_request_special = no
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
readme_directory = /usr/share/doc/postfix
receive_override_options = no_address_mappings
recipient_delimiter = +
relay_domains = mysql:/etc/postfix/mysql-virtual_relaydomains.cf
relay_recipient_maps = mysql:/etc/postfix/mysql-virtual_relayrecipientmaps.cf
relayhost = smtp.wanadoo.fr
smtp_sasl_auth_enable = yes
smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
smtp_sasl_security_options =
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
smtpd_client_message_rate_limit = 100
smtpd_client_restrictions = check_client_access mysql:/etc/postfix/mysql-virtual_client.cf
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_authenticated_header = yes
smtpd_sasl_path = private/auth
smtpd_sasl_type = dovecot
smtpd_sender_restrictions = check_sender_access mysql:/etc/postfix/mysql-virtual_sender.cf
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
smtpd_tls_security_level = may
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtpd_use_tls = yes
transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
virtual_alias_domains =
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, proxy:mysql:/etc/postfix/mysql-virtual_email2email.cf, hash:/var/lib/mailman/data/virtual-mailman
virtual_gid_maps = static:5000
virtual_mailbox_base = /var/vmail
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_transport = dovecot
virtual_uid_maps = static:5000
postconf: warning: /etc/postfix/master.cf: unused parameter: smtpd_bind_address=127.0.0.1
root@mail:/tmp/ispconfig3_install/install#
I've declared the SMTP relay in System > Server config > Email like you said.

I'm fetching correctly my mail. Still impossible to get outside

Edit: I have that problem only on domains that are defined on ISPConfig3. I can send mails outside to other domains. They don't get out if their domain exists in ISPConfig3.

Last edited by Tramis; 29th September 2012 at 08:11.
Reply With Quote