View Single Post
  #4  
Old 22nd September 2012, 04:03
fmarton fmarton is offline
Junior Member
 
Join Date: Sep 2012
Posts: 7
Thanks: 0
Thanked 2 Times in 2 Posts
Smile Solution found

Took a while, but I finally solved it.
The grep -r '/var/vmail' did not find the /home/vmail/.mailfilter file which contained the entries for /var/vmail.

So if anyone else interested how to change the maildir location after completing this tutorial, I succeded to change /var/vmail to /home/vmail by following these steps:

1: Change maildir and homedir entries in ISPConfig: System -> Server config -> Mail page
2: Copy the vmail folder to the appropriate location: cp -a /var/vmail /home/vmail
3: Update vmail system user's home directory: usermod -d /home/vmail vmail
4: Set virtual_mailbox_base = /home/vmail in /etc/postfix/main.cf file
5: Update all /var/vmail entries to /home/vmail in /home/vmail/.mailfilter file
6: chown -R vmail:vmail /home/vmail
7: restart all mail services

Make sure that the quota mount options in /etc/fstab are added to the correct drive/partition containing the new maildir folder. (I already did it during the initial setup)

Cheers,
Marton
Reply With Quote