View Single Post
  #5  
Old 20th September 2012, 22:58
Unfaiir Unfaiir is offline
HowtoForge Supporter
 
Join Date: Jul 2012
Location: Orange County, CA, USA
Posts: 43
Thanks: 14
Thanked 4 Times in 2 Posts
Unhappy Update...

I looked into how my sites were setup in ISPConfig 3 and they were all set to use * as the IP. One by one I went in and set them to the server IP instead of * in ISPConfig.

I noticed two interesting things. First, when I set any site to use the server IP instead of *, it would no longer work. Second, whenever I set whatever site was acting as the "default site" to not use * as the IP, another site that still was using * as the IP would become the new "default site". It seems as though the most recent site that was setup in ISPConfig 3 to use * as the IP will become the "default site". This is bad, I need to control which site is the "default site", not let the "most recent * IP site" become the new goto "default site" for all non-existent sub domains or by directly entering the site IP into the browser.

After all sites were no longer using * as the IP, I noticed that none of my sites would load and that /var/www/html was now being used as the "default site".

Ok.. what is going on here? To me it seems like some kind of IP configuration issue. So I go into my /var/www/html and drop in a phpinfo(); and take a look.

I noticed that when I scroll down to Apache vars and i see my servers internal IP address instead of my servers public IP address. My server is behind a router which routes all incoming traffic to the server on a static internal IP:

Code:
SERVER_ADDR 	192.168.2.111
I believe I see what is happening here. I set ISPConfig to have the sites use my servers public IP address, however, here is my internal IP address being used by Apache. Something is a miss here in IP land and I'm not sure exactly what it is or how to fix it.

Does anyone know how to configure this router/server/IP situation to work correctly with ISPConfig? It seems I must have done something wrong with the IP configuration or forgot something, but I don't see what yet.

My server is behind a router, which then assigns the server an internal static IP of 192.168.2.111. I need ISPConfig to let the public IP be the ONLY choosable IP in the drop down when setting up a site though. I don't want 192.168.2.111 to show up in the drop down at all for anyone to choose as their IP.

My goal is to let a client of mine use this system too for their site and I don't want to allow them or make them choose the server's internal IP if I don't have to. In fact, I'd rather they not be able to use * either because it seems like whatever site is the "LAST" site to enter * as their IP becomes the latest and greatest "default site" for the server according to ISPConfig. I don't want my client to become the default site just because she used * as her site IP after me.

Can anyone help?

Last edited by Unfaiir; 20th September 2012 at 23:05.
Reply With Quote