View Single Post
  #12  
Old 10th September 2012, 21:34
gscales gscales is offline
Member
 
Join Date: May 2012
Posts: 34
Thanks: 1
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by falko View Post
Are you absolutely sure then that your email client settings are ok? There should at least be something in the mail log when you try to connect...
I'd like to thank you, Falko, for your attempts to help. After reading a lot and just sitting down and reasoning for a while, I've concluded that the data center where we rent the server has port 25 blocked to outgoing traffic.

Your guides on this website are absolutely great. I followed the guide for the Perfet Server using Ubuntu 10.04 LTS. Everything else worked, so my reasoning is that this should have worked as well.

I added the following line to the master.cf :

submission inet n - - - - smtpd
-o smtpd_sasl_auth_enable=yes
-o smtpd_client_restrictions=permit_sasl_authenticate d,reject

This enables the smtp daemon to send through the submission port, 587. After updating my email client (Thunderbird) to reflect 587 instead of 25, and adding port 587 to ISPConfig's firewall rule, sending worked. Since the only thing I really changed was the outbound port (from 25 to 587), I must conclude that the data center provider has outbound port 25 traffic blocked.

One last question, Falko: if I remove 25 from the firewall rule, that should effetively block inbound traffic on port 25. Will internal, localhost, email still work even though I block the port from inbound requests?

Thanks so much for your help!

Greg
Reply With Quote