View Single Post
  #1  
Old 7th September 2012, 17:22
sheshes sheshes is offline
Senior Member
 
Join Date: Aug 2009
Location: Nicosia
Posts: 123
Thanks: 2
Thanked 0 Times in 0 Posts
Default Huge Problems after release upgrade

Guys, I have done a release upgrade from 10.04 to 12.4 ubuntu.

During the upgrade it asked if the scripts and config files modified should be updated and answered NO.

After finishing the upgrade and after rebooting the system a lot are not working.

Mydns fails to start giving error

Starting DNS server: mydns/usr/local/sbin/mydns: error while loading shared libraries: libmysqlclient.so.16: cannot open shared object file: No such file or directory

libmysqlclient16 is obsolete and libmysqlclient18 is installed.

I tried downloading the latest version of mydns and when i run ./configure it terminates with error:

checking for MySQL support... no
checking for PostgreSQL support... no
checking which database to use... none
configure: error: No supported database found. Either MySQL or PostgreSQL is required.

This is very strange to me as the database should stay intact after upgrade.

As a result my webpages and emails don't work. I can only enter ISPconfig 3 control panel but in there everything looks fine besides the mail-error and mail-warning log caused by the problem with mydns above.

If somebody can help please do so urgently! All the office is now paralysed.

Thanks in advance
Reply With Quote
Sponsored Links