View Single Post
  #1  
Old 15th August 2012, 19:18
Croydon Croydon is offline
ISPConfig Developer
 
Join Date: Jul 2007
Location: Koblenz, Germany
Posts: 932
Thanks: 16
Thanked 264 Times in 208 Posts
Default Problem when deleting websites

There seems to be a problem in current svn version (don't know about earlier versions) when deleting websites.

rm: Entfernen von „/var/www/clients/client1/web2/web“ nicht möglich: Keine Berechtigung

and same message with all the folders in the web2 dir.

ls -ld /var/www/clients/client1/web2/web
drwx--x--- 2 web2 client1 4096 15. Aug 17:56 /var/www/clients/client1/web2/web

It seems even root cannot delete this, I tried a rm -r and rm -rf but same error.

After a few tests I realized that the web1 and web2 directories have the immutable bit set (chattr +i web2), so it can online be deleted if I do a chattr -i web2 first.
It seems that this step is missing on deleting a web (maybe on renaming or moving, too), so a web does not get deleted, including its vhost file.

This is no problem as long as no one tries to recreate a web with the same domain later on. If you try this you mess up your installation as the new web is not created correctly (logfile path missing, wrong vhost file).
__________________
Marius Cramer

pixcept KG
Reply With Quote
Sponsored Links