View Single Post
  #1  
Old 10th August 2012, 08:43
rockey rockey is offline
Junior Member
 
Join Date: Aug 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Angry Installing XEN on Centos 6.3 X86_64 ... Problem xen not starting...!!!

Hi,

I followed tutorial http://www.howtoforge.com/virtualiza...virtualization

To install xen on Centos 6.3 everything is going perfect but, after editing /boot/grub/menu.lst

Quote:
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,0)
# kernel /vmlinuz-version ro root=/dev/mapper/vg_xen-LogVol01
# initrd /initrd-[generic-]version.img
#boot=/dev/sdb
default=0
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title CentOS (2.6.32.57-2.el6xen.x86_64)
root (hd0,0)
kernel /xen.gz dom0_mem=1024M cpufreq=xen dom0_max_vcpus=1 dom0_vcpus_pin
kernel /vmlinuz-2.6.32.57-2.el6xen.x86_64 ro root=/dev/mapper/vg_xen-LogVol01 rd_NO_LUKS LANG=en_US.UTF-8 rd_LVM_LV=vg_xen/LogVol01 rd_LVM_LV=vg_xen/lv_swap rd_NO_MD SYSFONT=latarcyrheb-sun16 crashkernel=128M KEYBOARDTYPE=pc KEYTABLE=us rd_NO_DM rhgb quiet
initrd /initramfs-2.6.32.57-2.el6xen.x86_64.img

title CentOS (2.6.32-279.el6.x86_64)
root (hd0,0)
kernel /vmlinuz-2.6.32-279.el6.x86_64 ro root=/dev/mapper/vg_xen-LogVol01 rd_NO_LUKS LANG=en_US.UTF-8 rd_LVM_LV=vg_xen/LogVol01 rd_LVM_LV=vg_xen/lv_swap rd_NO_MD SYSFONT=latarcyrheb-sun16 crashkernel=128M KEYBOARDTYPE=pc KEYTABLE=us rd_NO_DM rhgb quiet
initrd /initramfs-2.6.32-279.el6.x86_64.img

when i reboot it is booted with xen kernel but when i run command

xm info or xm list

Quote:
showing error " Error: Unable to connect to xend: No such file or diectory. Is xend running "
when i run command

xend start

showing error

Quote:
" xc: error: Could not obtain handle on privileged command interface (2 = No such file or directory): Internal error
xend/image.py: Error connecting to hypervisor "
ls /proc/xen

Quote:
" ls: cannot access /proc/xen: No such file or directory "
added entry in /etc/fstab

Quote:
none /proc/xen xenfs default 0 0
after reboot gives error no such file or directory,

Quote:
lsmod | grep -i xen output: Nothing...

modprob xen-evtchn

FATAL: Error inserting xen_evtchn (/lib/modules/2.6.32.57-2.el6xen.x86_64/kernel/drivers/xen/xen-evtchn.ko): No such device

modprob xen-gntdev

FATAL: Error inserting xen_gntdev (/lib/modules/2.6.32.57-2.el6xen.x86_64/kernel/drivers/xen/xen-gntdev.ko): No such devic
e

I tried another tutorial https://www.crc.id.au/xen-on-rhel6-s...entos-6-howto/

it seems like nothing is working for me...

Guys... please share your thoughts about this problem...

Thank you.
Reply With Quote
Sponsored Links