View Single Post
  #2  
Old 9th August 2012, 01:07
FSNTiger FSNTiger is offline
Junior Member
 
Join Date: Sep 2011
Posts: 27
Thanks: 0
Thanked 4 Times in 3 Posts
Default

I tried a couple of things, finally down to forcing ISPConfig to reconfigure all the services. Still at the same point except the error is different:

amavis[28240]: (28240-01) (!)ClamAV-clamd: Can't connect to UNIX socket /var/spool/amavisd/clamd.sock: 2, retrying (2)

So I checked ClamD and its not running, attempts to start it fail with:
ERROR: Can't open /var/log/clamav/clamd.log in append mode (check permissions!).
ERROR: Can't initialize the internal logger

Tried to adjust the permissions for the log file. No luck. Deleted the log.
rm /var/log/clamav/clamd.log
touch /var/log/clamav/clamd.log
chown clamav /var/log/clamav/clamd.log

Then I get error:
LibClamAV Error: cl_cvdhead: Can't read CVD header in /var/clamav/daily.cld
LibClamAV Error: cli_loaddbdir(): error parsing header of /var/clamav/daily.cld
ERROR: Malformed database

Removed the Daily.cld

Then Error:
LibClamAV Warning: **************************************************
LibClamAV Warning: *** The virus database is older than 7 days! ***
LibClamAV Warning: *** Please update it as soon as possible. ***
LibClamAV Warning: **************************************************
LibClamAV Error: cli_cvdverify: Can't read CVD header
LibClamAV Error: Can't load /var/clamav/main.cld: Broken or not a CVD file
ERROR: Broken or not a CVD file

So I delete that one as well. Then run Freshclam to update.

Then start the service, all is well except it still tells me the virus DB is 7 days out of date?
Freshclam completes and says the files are up to date.
Reply With Quote