View Single Post
  #3  
Old 19th July 2012, 15:25
mexxchan mexxchan is offline
Junior Member
 
Join Date: Apr 2010
Posts: 6
Thanks: 1
Thanked 1 Time in 1 Post
Default

Thanks !!!

I follow the thread but failed initially . However, after some attempts I figured out that I need to add "-update" in the command in order to make it.

One further thing is that the -log parameter doesn't work too, hence I have to manually create the soft link to the right web.log and then it works. (that's pretty easy). And it is also necessary to empty all the files in the "web/awstats" folder first (I don't know why I need to do it but if I don't then there is no generation of the past statistics, strange thing.)

The commands I used (for generating the Jan / Feb/ Mar 2012) are:

yes | rm /var/www/www.[domain].com/log/web.log
ln -s /var/www/www.[domain].com/log/2012/01/web.log /var/www/www.[domain].com/log/web.log
perl /home/admispconfig/ispconfig/tools/awstats/tools/awstats_buildstaticpages.pl -year=2012 -month=01 -update -config=www.[domain].com -awstatsprog=/home/admispconfig/ispconfig/tools/awstats/wwwroot/cgi-bin/awstats.pl -builddate=2012-01 -dir=/var/www/web105/web/awstats

yes | rm /var/www/www.[domain].com/log/web.log
ln -s /var/www/www.[domain].com/log/2012/02/web.log /var/www/www.[domain].com/log/web.log
perl /home/admispconfig/ispconfig/tools/awstats/tools/awstats_buildstaticpages.pl -year=2012 -month=02 -update -config=www.[domain].com -awstatsprog=/home/admispconfig/ispconfig/tools/awstats/wwwroot/cgi-bin/awstats.pl -builddate=2012-02 -dir=/var/www/web105/web/awstats

yes | rm /var/www/www.[domain].com/log/web.log
ln -s /var/www/www.[domain].com/log/2012/03/web.log /var/www/www.[domain].com/log/web.log

After that, it is necessary to re-run the cronjob of the awstats (I think it build the index.html file) , and now all is ok.

Thanks again.

Last edited by mexxchan; 19th July 2012 at 15:36.
Reply With Quote