View Single Post
  #4  
Old 3rd July 2012, 23:09
nzimas nzimas is offline
Member
 
Join Date: May 2007
Posts: 47
Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation

Hi Falko,

Things are gettung more interesting.
After reinstalling everything from the ground up, eventually I have managed to enable php-fpm.

However, upon switching to unix socket mode, Lighttpd throws the following error:
Quote:
2012-07-03 22:02:30: (mod_fastcgi.c.2854) fcgi-server re-enabled: unix:/tmp/php5-fpm.sock
2012-07-03 22:02:34: (mod_fastcgi.c.1734) connect failed: Connection refused on unix:/tmp/php5-fpm.sock
2012-07-03 22:02:34: (mod_fastcgi.c.3027) backend died; we'll disable it for 1 seconds and send the request to another backend instead: reconnects: 0 load: 1
2012-07-03 22:02:35: (mod_fastcgi.c.3597) all handlers for /index.php? on .php are down.

I must add that I had to touch /tmp/php5-fpm.sock because it was not automatically created by neither lighttpd nor php-fpm.

Quote:
root@rtvnwebfpm:~# ls -l /tmp/php5-fpm.sock
-rw-r--r-- 1 www-data www-data 0 Jul 3 21:59 /tmp/php5-fpm.sock
[EDIT]

Aghh... my extremely poor sight playing tricks on me. Copied isten = /tmp/php5-fpm.sock instaed of listen = /tmp/php5-fpm.sock
Sorry about that

Last edited by nzimas; 4th July 2012 at 01:56. Reason: Error found
Reply With Quote