View Single Post
  #1  
Old 3rd July 2012, 17:51
krisztian.kocsis krisztian.kocsis is offline
Junior Member
 
Join Date: Jul 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Postfix does not accept incoming emails targeted to mailman virtual accounts

Hi!

I'v configured ISP Config few months ago on my server and now I created a new mailing list in ISP Config admin. The mailing list can be configured via mailman GUI and I receive system mails without problems, but if I try to send a mail to that mailing list then postfix returns the mail because it unable the deliver (unknown user).

Virtual mailman alias files contain the required entries!

Here is the postconf output:

alias_database = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
alias_maps = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
append_dot_mydomain = no
biff = no
body_checks = regexp:/etc/postfix/body_checks
broken_sasl_auth_clients = yes
config_directory = /etc/postfix
content_filter = amavis:[127.0.0.1]:10024
header_checks = regexp:/etc/postfix/header_checks
inet_interfaces = all
inet_protocols = all
mailbox_size_limit = 0
message_size_limit = 0
mime_header_checks = regexp:/etc/postfix/mime_header_checks
mydestination = localhost
myhostname = optimaster.eu
mynetworks = 127.0.0.0/8 [::1]/128
myorigin = /etc/mailname
nested_header_checks = regexp:/etc/postfix/nested_header_checks
owner_request_special = no
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
readme_directory = no
receive_override_options = no_address_mappings
recipient_delimiter = +
relay_domains = mysql:/etc/postfix/mysql-virtual_relaydomains.cf
relay_recipient_maps = mysql:/etc/postfix/mysql-virtual_relayrecipientmaps.cf
relayhost =
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
smtpd_client_message_rate_limit = 100
smtpd_client_restrictions = check_client_access mysql:/etc/postfix/mysql-virtual_client.cf
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_authenticated_header = yes
smtpd_sasl_path = private/auth
smtpd_sasl_security_options = noanonymous
smtpd_sasl_type = dovecot
smtpd_sender_restrictions = check_sender_access mysql:/etc/postfix/mysql-virtual_sender.cf
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
smtpd_tls_security_level = may
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtpd_use_tls = yes
transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
virtual_alias_domains =
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, proxy:mysql:/etc/postfix/mysql-virtual_email2email.cf, hash:/var/lib/mailman/data/virtual-mailman
virtual_gid_maps = static:5000
virtual_mailbox_base = /var/vmail
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_transport = dovecot
virtual_uid_maps = static:5000

Mail log:

Jul 3 15:15:50 optimaster postfix/qmgr[26474]: E484614615B2: from=<krisztian.kocsis@optimaster.eu>, size=1504, nrcpt=1 (queue active)
Jul 3 15:15:50 optimaster amavis[19291]: (19291-16) Passed CLEAN, LOCAL [127.0.0.1] [127.0.0.1] <krisztian.kocsis@optimaster.eu> -> <staff@optimaster.eu>, Message-ID: <b3be26210c02615aedb8fe87b4e1470b@optimaster.eu> , mail_id: IpIZlP48CadZ, Hits: -0.275, size: 1066, queued_as: E484614615B2, 238 ms
Jul 3 15:15:50 optimaster postfix/smtp[26643]: 93E431460A5A: to=<staff@optimaster.eu>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.43, delays=0.19/0.01/0/0.24, dsn=2.0.0, status=sent (250 2.0.0 from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as E484614615B2)
Jul 3 15:15:50 optimaster postfix/qmgr[26474]: 93E431460A5A: removed
Jul 3 15:15:50 optimaster postfix/pipe[26648]: E484614615B2: to=<staff@optimaster.eu>, relay=dovecot, delay=0.17, delays=0.09/0.01/0/0.08, dsn=5.1.1, status=bounced (user unknown. Command output: doveconf: Warning: NOTE: You can get a new clean config file with: doveconf -n > dovecot-new.conf doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:23: 'imaps' protocol is no longer necessary, remove it doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:23: 'pop3s' protocol is no longer necessary, remove it doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:93: ssl_disable has been renamed to ssl doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:101: ssl_cert_file has been replaced by ssl_cert = <file doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:102: ssl_key_file has been replaced by ssl_key = <file doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:152: login_process_size has been replaced by service { vsz_limit } doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:158: login_process_per_connection has been replaced by service { service_count } doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:161: login_processes_count has been replaced by service { process_min_avail } doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:169: login_max_processes_count has been replaced by service { process_limit } doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:176: login_max_connections has been replaced by service { client_limit } doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:311: fsync_disable has been renamed to mail_fsync doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:345: max_mail_processes has been replaced by service { process_limit } doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:349: mail_process_size has been replaced by service { vsz_limit } doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:498: dbox_rotate_
Jul 3 15:15:50 optimaster postfix/cleanup[26642]: 1AA8714615B6: message-id=<20120703131550.1AA8714615B6@optimaster.eu>
Jul 3 15:15:50 optimaster postfix/bounce[26650]: E484614615B2: sender non-delivery notification: 1AA8714615B6
Jul 3 15:15:50 optimaster postfix/qmgr[26474]: 1AA8714615B6: from=<>, size=10949, nrcpt=1 (queue active)
Jul 3 15:15:50 optimaster postfix/qmgr[26474]: E484614615B2: removed
Jul 3 15:15:50 optimaster dovecot: lda(krisztian.kocsis@optimaster.eu): sieve: msgid=<20120703131550.1AA8714615B6@optimaster.eu>: stored mail into mailbox 'INBOX'
Jul 3 15:15:50 optimaster postfix/pipe[26648]: 1AA8714615B6: to=<krisztian.kocsis@optimaster.eu>, relay=dovecot, delay=0.16, delays=0.06/0/0/0.1, dsn=2.0.0, status=sent (delivered via dovecot service)
Jul 3 15:15:50 optimaster postfix/qmgr[26474]: 1AA8714615B6: removed
Reply With Quote
Sponsored Links