View Single Post
  #8  
Old 30th June 2012, 14:28
sjswarts sjswarts is offline
Senior Member
 
Join Date: May 2011
Location: Australia
Posts: 135
Thanks: 17
Thanked 5 Times in 5 Posts
Default

g'day sjau,

don't know what I did wrong but hyper_ch on the horde irc channel helped out and told me to add this to my horde.conf file...

Code:
AddType application/x-httpd-php .php
So in complete form it looks like this...

Code:
Alias /autodiscover/autodiscover.xml /var/www/horde/rpc.php
Alias /Microsoft-Server-ActiveSync /var/www/horde/rpc.php
Alias /horde /var/www/horde
<Directory /var/www/horde>
           Options +FollowSymLinks
           AllowOverride None
           order allow,deny
           allow from all
           AddType application/x-httpd-php .php
           php_value include_path ".:/usr/share/php"
           php_value open_basedir "none"
           php_value upload_tmp_dir "/var/www/horde/phptmp/"
</Directory>

RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}
This enables me to run on both http and https but I want to FORCE https...

My issue now is that the rewrite doesn't work... people can still access my site by using port 80
Reply With Quote