View Single Post
  #1  
Old 19th June 2012, 23:48
NeonNexxus NeonNexxus is offline
Junior Member
 
Join Date: Jun 2012
Posts: 11
Thanks: 0
Thanked 2 Times in 1 Post
Default [SOLVED] Xen On CentOS 6.2 (x86_64)

Hi there everybody and Falko.

I was trying to install XEN on a CentOS 6.2 (x86_64) and following the guide at http://www.howtoforge.com/virtualiza...virtualization but I ran out of luck.
Please bear with me and let me explain.
I have a web hosted server in Germany and I am nowhere near it.
The server I can reinstall Centos 6.2 minimal install as many times as i want (thank GOD).
Ok now on to business.
After the CentOS 6.2 minimal install I run this commands. Since I want to have the GUI remotely I start by installing the Desktop. and then moving to the guide.

=========================

yum install @basic-desktop
yum groupinstall "Desktop Platform"
yum install xorg-x11-fonts-misc
yum install xorg-x11-fonts-Type1
yum install tigervnc-server
yum install vim
vim /etc/sysconfig/vncservers
adduser mxxxxxx
passwd mxxxxx
su - mxxxxx
vncpasswd as mxxxx
exit - back to root
service vncserver start
yum list firefox
yum install firefox.x86_64
vim /etc/sysconfig/selinux - Disabaled
yum install bridge-utils
cd /etc/yum.repos.d/
ls -l

wget http://www.crc.id.au/repo/kernel-xen...6-3.noarch.rpm
rpm -Uvh kernel-xen-release-6-3.noarch.rpm

Falko has on his guide this command but it did not worked for me.
cd /etc/yum.repos.d/
wget http://www.crc.id.au/repo/kernel-xen.repo


Then I keep going ..

yum install kernel-xen xen
vim /boot/grub/menu.lst
yum install libvirt python-virtinst
yum groupinstall 'Development Tools'
yum install python-devel xen-devel libxml2-devel xhtml1-dtds readline-devel ncurses-devel libtasn1-devel gnutls-devel augeas libudev-devel

libpciaccess-devel yajl-devel sanlock-devel libpcap-devel libnl-devel avahi-devel libselinux-devel cyrus-sasl-devel parted-devel device-mapper-devel

numactl-devel libcap-ng-devel netcf-devel libcurl-devel audit-libs-devel systemtap-sdt-devel
rpm -qa | grep libvirt
mkdir /root/src
cd /root/src
wget http://vault.centos.org/6.2/os/Sourc...23.el6.src.rpm
rpm -i libvirt-0.9.4-23.el6.src.rpm
wget http://pasik.reaktio.net/xen/patches...able-xen.patch
cd /root/rpmbuild/SPECS
cp -a libvirt.spec libvirt.spec.orig
patch -p0 < ~/src/libvirt-spec-rhel6-enable-xen.patch
rpmbuild -bb libvirt.spec
cd /root/rpmbuild/RPMS/x86_64/
rpm -Uvh --force libvirt-0.9.4-23.el6.x86_64.rpm libvirt-client-0.9.4-23.el6.x86_64.rpm libvirt-python-0.9.4-23.el6.x86_64.rpm

Everything works great until here.

reboot
#uname -a -- Displays

Linux CentOS-62-64-minimal 2.6.32.57-2.el6xen.x86_64 #1 SMP Fri May 25 14:05:24 EST 2012 x86_64 x86_64 x86_64 GNU/Linux

#xm list -- Displays

Name ID Mem VCPUs State Time(s)
Domain-0 0 1024 4 r----- 30.2


But .. and here is the big BUT <-


#virsh list -- Dislpays

Id Name State
----------------------------------

#virsh list comes out empty.
So I can not connect to anything.
I have tried almost everything googling around but with no luck
Thank you in advanced everyone.
Ed
Reply With Quote
Sponsored Links