View Single Post
  #2  
Old 4th June 2012, 13:17
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,482
Thanks: 813
Thanked 5,255 Times in 4,121 Posts
Default

Quote:
Everything else is working fine but obviously billing is an important feature so I need this to be correct. On my Global Settings -> Payment gateways configuration I have all fields specified and PayPal enabled, other than "Link to payment page (otional)" which I understood was only to replace the default URL which should have been correct, above.
Set the correct URL that matches your installation for the billing gateway page under Global Settings -> Payment gateways > Link to payment page (otional)

The link has to be like this:

Code:
http://www.yourdomain.tld:8080/billing/payments/pay.php?id=
where "www.yourdomain.tld:8080" is the URL and port were your ispconfig controlpanel can be reached. The URL in this field has to end with =, the ID is added at the end automatically.

Quote:
I have noticed that on the Billing -> Client List -> Settings the Payment Gateway is set to "None" - does this need to be "Auto" for all clients in order to work as I expect it to ?
Non means disabled, so its correct that you get the error message that you disabled the billing gateway.

If you need help with the billing module, please contact our support by email to support [at] ispconfig [dot] org.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote