View Single Post
  #2  
Old 23rd May 2012, 10:37
suaswe suaswe is offline
Junior Member
 
Join Date: May 2012
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

OK, I checked my domain registration account and noticed that I had my mx record configured as "mx.example.com" even though it's really only one server. I updated this to just "example.com" and got a "Connection refused" return message in GMail instead.

Tried telnetting to my domain on port 25 - connection refused. To localhost it worked fine; initially suspected iptables but it is definitely open for smtp. Had a look on the server and, since restarting the server last night, once again sendmail had switched itself on with postfix being off. Thought I had already sorted this in chkconfig but obviously not! Set 'chkconfig sendmail off' and 'chkconfig postfix on', turned sendmail off, turned postfix on, tried telnetting from outside again, and it now opens:

[user@exthost ~]$ telnet example.com 25
Trying x.x.x.x...
Connected to example.com.
Escape character is '^]'.
220 example.com ESMTP Postfix
quit
221 2.0.0 Bye
Connection closed by foreign host.

Google messages now coming through finally - hurraaaaaaaaaah! I have tried to remove sendmail totally before but without success, it always results in dependencies not being met and everything falling apart. Does anyone know a good way to ensure that it never runs unbidden? On a related note, I'm still seeing sendmail logs in maillog, e.g.:

Code:
[user@example ~]$ grep sendmail /var/log/maillog | tail -5
May 23 09:19:49 example sendmail[2197]: alias database /etc/aliases rebuilt by user
May 23 09:19:49 example sendmail[2197]: /etc/aliases: 78 aliases, longest 10 bytes, 788 bytes total
May 23 09:30:52 example sendmail[2342]: q4N8Uqlv002342: from=user, size=225, class=0, nrcpts=1, msgid=<201205230830.q4N8Uqlv002342@example.com>, relay=user@localhost
May 23 09:30:52 example sendmail[2342]: STARTTLS=client, relay=[127.0.0.1], version=TLSv1/SSLv3, verify=FAIL, cipher=DHE-RSA-AES256-SHA, bits=256/256
May 23 09:30:52 example sendmail[2342]: q4N8Uqlv002342: to=user@gmail.com, ctladdr=user (500/5001), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30225, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (Ok: queued as DA21F1E0D8A)
Is this normal? E.g. is it in fact some sendmail process within postfix that's doing this?

I sadly also still have issues with Squirrelmail, in that I'm just getting a blank page loading with URL http://example.com/webmail/src/webmail.php when trying to log on. Anyone know how I might go about fixing this?

Last edited by suaswe; 23rd May 2012 at 11:02.
Reply With Quote