View Single Post
  #3  
Old 14th May 2012, 13:37
vestport4 vestport4 is offline
Junior Member
 
Join Date: Jun 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hello Falko,

When you say place cgi files in the cgi-bin directory. Does it make a difference that it is actually named cgi-bin? I mean I know that is traditional or whatever but as long as there is +ExecCGI and AddHandler cgi-script .cgi
AddHandler cgi-script .pl it cgi files should be able to go anywhere no?

Or are you saying that .cgi files cannot be run on the virtual host and need to be in the main /cgi-bin/directory of the host that handles all the virtual domains?

Part of the problem is that I can't even do a directory listing like I use to be able to do in non-cgi directories on ISPCONFIG2. Like when I would:

Code:
http://www.mydomain.com/files/
I would see:

Code:
file1
file2
file3
Now all I get is an error.

The only way I can see a file is if I actually know what it is like:

Code:
http://www.mydomain.com/files/file1
I cannot do a directory listing even with Options +Indexex. I figured that this is one and the same problem why I can't use my cgi files.

Do apache directives take precedence over the .vhost files or rather is there anything in the .vhost files that would overwrite apache directives preventing me from running cgi and listing directories?

Below are my apache directives that I have been trying with no luck:

Code:
<Directory /var/www/clients/client1/web1/files/>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
</Directory>

<Directory /var/www/clients/client1/web1/files/cgi/
AddHandler cgi-script .cgi .pl
Options FollowSymLinks +ExecCGI 
</Directory>
I used this with and without a + on Indexes and no luck

After changes I would:

Code:
/etc/init.d/httpd restart
and wait a few secs for changes to take effect.

Am I doing something wrong?


Thanks for advice about where to keep files and overwrites. Now I know how to handle that once I get directory listings and cgi working right.


Thanks,


Art
Reply With Quote