View Single Post
  #3  
Old 14th May 2012, 10:42
mccyberix mccyberix is offline
Member
 
Join Date: Aug 2006
Posts: 69
Thanks: 0
Thanked 0 Times in 0 Posts
Default

thanks for reply falko,
you mean on the active loadbalancer I guess, because the nodes behind doesnt have virtual IP's, as far as I have understood the behavior of HAProxy is that it will route the requests hitting the virtual IP to one of the backend nodes where both nodes are always active but maybe I'm wrong...
ok, when I do a 'ifconfig' I do not see the virtual IP on both loadbalancers but when I do 'ip addr sh eth0' I will see it

ifconfig output:
Quote:
Load balancer A

eth0 Link encap:Ethernet HWaddr xx:xx:xx:xx:xx:xx
inet addr:192.168.1.105 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: xxxx::xxx:xxxx:xxx:xxxx/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:2077714 errors:0 dropped:0 overruns:0 frame:0
TX packets:2616483 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:213504803 (203.6 MiB) TX bytes:179658037 (171.3 MiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:6440 errors:0 dropped:0 overruns:0 frame:0
TX packets:6440 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:685982 (669.9 KiB) TX bytes:685982 (669.9 KiB)

Load balancer B

eth0 Link encap:Ethernet HWaddr xx:xx:xx:xx:xx:xx
inet addr:192.168.1.106 Bcast:192x168x1.255 Mask:255.255.255.0
inet6 addr: xxxx::xxx:xxxx:xxxx:xxxx/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:2332208 errors:0 dropped:0 overruns:0 frame:0
TX packets:2327326 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:240938546 (229.7 MiB) TX bytes:164913693 (157.2 MiB)
Interrupt:18 Base address:0x2000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:5636 errors:0 dropped:0 overruns:0 frame:0
TX packets:5636 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:506376 (494.5 KiB) TX bytes:506376 (494.5 KiB)
ip addr sh eth0 output on the active LB, my virtual IP is '192.168.1.100'

Quote:
active load balancer

2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
link/ether xx:xx:xx:xx:xx:xx brd ff:ff:ff:ff:ff:ff
inet 192.168.1.101/24 brd 192.168.1.255 scope global eth0
inet 192.168.1.100/24 scope global eth0
inet6 xxxx::xxx:xxxx:xxxx:xxxx/64 scope link
valid_lft forever preferred_lft forever
when I bring down the active load balancer the virtual IP wil be passed to the second one as it should.

I've made some testing and come to that point that squirrelmail is not able to authenticate logins when reached over the virtual IP, when I connect directly to one of the backends IP's there is no problem to log in. This is the only thing what I realy have to change since I dont realy need to connect to ISPConfig via my virtual IP.

thanks in advance!
Reply With Quote