View Single Post
  #14  
Old 13th May 2012, 19:27
dharake dharake is offline
Junior Member
 
Join Date: May 2012
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi Till, popping in to evesdrop this conversation... my problem is that I cannot login to phpmyadmin with a client's credentials. I have followed the steps that you posted to get debug info, and here is my ouput:


root@db:~# /usr/local/ispconfig/server/server.sh

13.05.2012-16:09 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig _lock
13.05.2012-16:09 - DEBUG - Found 1 changes, starting update process.
13.05.2012-16:09 - DEBUG - Replicated from master: REPLACE INTO web_database (`d atabase_id`,`sys_userid`,`sys_groupid`,`sys_perm_u ser`,`sys_perm_group`,`sys_per m_other`,`server_id`,`type`,`database_name`,`datab ase_user`,`database_password`, `database_charset`,`remote_access`,`remote_ips`,`a ctive`) VALUES ('2','1','2','r iud','ru','','3','mysql','c1test','c1danny2','','' ,'y','','y')
13.05.2012-16:09 - DEBUG - Calling function 'db_insert' from plugin 'mysql_clien tdb_plugin' raised by event 'database_insert'.
13.05.2012-16:09 - DEBUG - Created MySQL database: c1test
13.05.2012-16:09 - DEBUG - Processed datalog_id 9
13.05.2012-16:09 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispcon fig_lock
finished.

So in my case it seems to have created the user and database, but I can't access it.

The steps I took were:
1. I went into ISPConfig 3.0.4.5 and created a client
2. Logged in to ISPC as that client
3. Created new databse and user
4. Clicked the manage icon which opened up 31.222.179.30:8080/phpmyadmin/
5. Tried to login with the client db credentials, and get "#1045 Cannot log in to the MySQL server"

Any help would be very appreciated. Thanks in advance

---------------------------

So turns out after hours of fiddling that the problem was me being a moron....

in my.cnf I had commented out bind-address like so "#bind" instead of "# bind".... For you newbies, notice the space?

All works ok now

Last edited by dharake; 13th May 2012 at 23:40. Reason: Solved
Reply With Quote