View Single Post
  #1  
Old 11th May 2012, 13:15
Grob.Charl Grob.Charl is offline
Junior Member
 
Join Date: May 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Angry Arch Linux: Dansguardian and Squid resets connection...

Hi All... Name is Charl Grobbelaar (South - Africa)

I am sitting with the weirdest problem. Squid and Dansguardian has been setup on a proxy and is working... not the way it should. The worst part of it is that I have done this setup a couple of times but I have been having a problem since I updated Arch-Linux Kernel to version 3.3...

Squid works perfectly fine in the sense that if I configure a pc to use the squid port... works beautifully... bot no filtering (abvious). Start Dansguardian... starts with no problem.

Configure the client pc's to use the Dansguardian assigned port... denies access to banned site (thats a good thing, so filter is working) and all other sites the client pc's get the message "The connection was reset"...

In short,
Squid working fine...
Dansguardian banning banned sites...
Dansguardian not allowing enything else unless you disable filtering...

Change the filter on dansguardian to not filter at all, and all sites open on all client pc's. The moment you enable filtering... my problem starts.

I have been using Linux now for the past about 2 years and I am at my wits end... tryed everythng including a fresh install of the operating system... still can't find the issue....

PLEEEEEAAASSSEEE HELP!
Reply With Quote
Sponsored Links