View Single Post
  #1  
Old 4th May 2012, 21:02
hakantuna hakantuna is offline
Junior Member
 
Join Date: May 2012
Posts: 5
Thanks: 1
Thanked 1 Time in 1 Post
Default Munin Plug-In :Error output from "oracle__locks" plugin on "CentOS 6.2"

Description

I get the following Error Message on my "munin-node.log" file. The same plug-in "oracle_locks" works on my VM (with Ubuntu 11 and Munin 1.4.5). What I don't understand is that I checked everthing, and I still get the same Error Message.

Error output from oracle_npk_locks: 2012/05/04-17:29:23 [19294] Can't exec "/etc/munin/plugins/oracle_npk_locks": Keine Berechtigung at /usr/share/perl5/vendor_perl/Munin/Node/Service.pm line 215. 2012/05/04-17:29:23 [19294] # ERROR: Failed to exec. 2012/05/04-17:29:23 [19294] Service 'oracle_npk_locks' exited with status 42/0.

Some infos about the Plug-in

[root@npk-co plugins]# ls -l oracle__locks
-rwxr-xr-x. 1 root root 4729 4. Mai 17:29 oraclelocks

[root@npk-co plugins]# ls -l oracle_npk_locks
lrwxrwxrwx. 1 root root 38 4. Mai 11:37 oracle_npk_locks -> /usr/share/munin/plugins/oraclelocks

When I execute it, The Script works

[root@npk-co plugins]# cd /usr/share/munin/plugins/
[root@npk-co plugins]# ./oracle__locks

RS.value 1
RE.value 0
S.value 0
SRX.value 0
X.value 0
MR.value 6
RT.value 1
XR.value 1
TS.value 1

Did you have any Idea? I do not understand the Problem. Please help me!

Last edited by hakantuna; 6th May 2012 at 19:27.
Reply With Quote
Sponsored Links