Thread: SSL issues
View Single Post
  #7  
Old 2nd May 2012, 04:19
profm2 profm2 is offline
Junior Member
 
Join Date: Mar 2011
Posts: 12
Thanks: 2
Thanked 2 Times in 2 Posts
Default

Ok, the steps that I took were:

1) Clean install from 12.04 (not required, but that iswhat I did) following the instructions from the Perfect Server for Ubuntu 11.10 w/ Nginx.

2) Follow the instructions for installing a Cert from StartSSL.

(both steps' Howto are in the first post)

3) In ISPConfig, in the System -> Server IP Addresses, created an entry for my server, using the internal address. In my case it's 192.168.1.100, the ifconfig address as mentioned by Falko. Make sure the ports specified are 80, 443.

4) In ISPConfig, in the Sites -> Websites, setup my webserver with the IP address from #3 in the IPv4 spot, and check the SSL checkbox a little lower down.

5) Go to the SSL tab in the Sites -> Website and type in your info that you used already to create the Cert and at the bottom of the screen for SSL Action select Create Certificate, and then Save.

6) The certificate is created (from ISPConfig) in /var/www/clients/clientX/webX/ssl

7) Take the certs created from step #2 and link them here ... so for instance I have a cert: URL.com.crt -> /usr/local/ispconfig/interface/ssl/ispserver.crt
(do a 'ln -s /usr/local/ispconfig/interface/ssl/ispserver.crt /var/www/clients/clientX/webX/ssl')

At this point, it SHOULD be setup. While doing mine, I had rebooted several times, so I would recommend after #7, reboot the server. You may not have to, but it never hurts.

NOTE: I just realized you were asking about Apache. I used Nginx for my webserver, however, with ISPConfig as a wrapper around us manually configuring the files, I believe the directories would be the same as far as the clients and such go. If you go into ISPConfig on the Sites -> Website -> Options tab, it'll tell you the actual directory for your client in "PHP open_basedir"

Last edited by profm2; 2nd May 2012 at 04:30. Reason: Apache v Nginx
Reply With Quote