View Single Post
  #12  
Old 30th April 2012, 10:54
fco fco is offline
Junior Member
 
Join Date: Apr 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks hanti.
I try another way:
- copy the template in conf-custom dir:
Code:
cp /usr/local/ispconfig/server/conf/nginx_vhost.conf.master /usr/local/ispconfig/server/conf-custom/
- move these 3 lines (141-143):

Code:
<tmpl_loop name="nginx_directives">
        <tmpl_var name='nginx_directive'>
</tmpl_loop>
at line 19 (under "root <tmpl_var name='web_document_root_www'>;").

In this way I can override nginx rules from web interface. For wordpress in site->options->nginx Directives I write:

Code:
location / {
   try_files $uri $uri/ /index.php?$args;
}

location ~ \.php$ {
            try_files $uri =404;
            include /etc/nginx/fastcgi_params;
            fastcgi_pass 127.0.0.1:9014;
            fastcgi_index index.php;
            fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
            fastcgi_param PATH_INFO $fastcgi_script_name;
            #fastcgi_intercept_errors on;
}
Can it be ?
Reply With Quote