Thread: SSL issues
View Single Post
  #3  
Old 30th April 2012, 00:59
profm2 profm2 is offline
Junior Member
 
Join Date: Mar 2011
Posts: 12
Thanks: 2
Thanked 2 Times in 2 Posts
Default

Quote:
Yes - just enable SSL for the website and create a self-signed cert through ISPConfig, and afterwards you go to the website's ssl directory, delete the cert, key, csr, and create symlink with the same names to where you stored your StartSSL cert.
Ok, did that. I'm guessing there's just one last step to enable Port 443 under Nginx. I do have the checkbox for SSL under the WebDomain->Domain tab checked, along with the info filled in for the SSL tab. I also verified that the System->Firewall allows port 443.

In the VHOST file under /etc/nginx/sites-enabled/100-SITENAME.vhost, I noticed that
Code:
server {
        listen *:80;
....
There is no "listen *:443;" ... so something is either incorrect, or not updating that vhost file.

Any thoughts? Thanks.

---------------------

EDIT: Ok, just poking around in my /etc/nginx/sites-available and found that I have a SITENAME.vhost.err file that DOES have the Listen 443 as the second line.

EDIT2: Upon further viewing of the log files at /var/log/ispconfig/cron.log, I found:
Code:
nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
nginx: [emerg] bind() to 75.x.x.x:443 failed (99: Cannot assign requested ad
dress)
nginx: configuration file /etc/nginx/nginx.conf test failed
So, it would appear that my IP address that I told it, is causing the issue. Am I right that the IP should be the static IP of the machine as seen from the outside world? *OR* the static IP of the internal IP on my local network?

Last edited by profm2; 30th April 2012 at 01:41. Reason: more info
Reply With Quote