View Single Post
  #1  
Old 23rd April 2012, 14:25
cyprus cyprus is offline
Member
 
Join Date: Oct 2011
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Default Wordpress Multisite get an 502

Hello last week I got ISPConfig to run after 2 weeks of hard work.
I resolved each task to get ISPcontig running on my server but the main point why I even thought about to switch my configuration is still not accomplished.

Before I start to describe the Problem here is my server config.
Debian Squeeze, Nginx , php-fpm, Postfix / Dovecot ,MySQL 5.5

Most stuff is fine ISPconfig seems to work like it should be. Postfix / Dovecot works as well.

I´ve uploaded a Flash Site to one of my webs and it works

I tried to move one of my Wordpress ms installation from an Apache environment, and this fails.
I know I can´t use the Apache .htaccess rules anymore and have to tell nginx what to do. I took the Nginx Config from the wordpress.org codex.
http://codex.wordpress.org/Nginx

The configuration is clear in most cases but there is one point which is not clear
Quote:
# Upstream to abstract backend connection(s) for PHP.
upstream php {
server unix:/tmp/php-fpm.sock;
# server 127.0.0.1:9000;
}
I implemented it as described but if I call a site I get an 502 Error.
Quote:
Folgender Fehler ist aufgetreten:

Dieser Server hat eine ungültige Antwort von einem Upstream-Server erhalten, auf den zugegriffen wurde, um die Anforderung zu erfüllen.
I get an invalid request from the Upstream Server.
And now I´m a littlebit lost. And need your inspiration to solve the problem.

Thank you in advance.
Cyprus
Reply With Quote
Sponsored Links