View Single Post
  #3  
Old 12th April 2012, 17:12
Jorge QWASS Jorge QWASS is offline
Junior Member
 
Join Date: Apr 2012
Posts: 4
Thanks: 3
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by till View Post
This is most likely a mysql connection problem so that the slave cant connect to the mysql on the amster anymore. This can e.g. happen when the login details are wrong or when a firewall was added on the master or when mysql on the master has been reconfigured to listen on localhost only.

You can test the connection by using the master login details from the file /usr/local/ispconfig/server/lib/config.inc.php from the slave server to connect to the master with the mysql command:

mysql -h master.server.tld -u ispcsrv1 -p dbispconfig
Till,

thank you very much for you fast answer. You saved my day.

As you said, it was mysql related. I tried your suggestion to find the next error:

ERROR 1129 (00000): Host 'mail.mydomain.tld' is blocked because of many connection errors; unblock with 'mysqladmin flush-hosts'

So that is what I did in the master server and suddenly all worked again.

According to that error, if I understand properly, the slave is creating some number of wrong connections with the master until they achieve the master limit and the slave is forbidden to access again. Is that true?. Is there some way to improve this?.

Thank you very much for you help.
Reply With Quote