View Single Post
  #4  
Old 8th April 2012, 11:19
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

Quote:
Originally Posted by DamianFick View Post
I managed to find a wordpress configuration on the wiki.nginx.org which is waaaay more mind boggling than the one shown on your tutorial. It even recodes your nginx.conf to work with wordpress, cluster servers, multi site compatibility, proxies, and caching.

Then it gave the optimized vhost code which needed me to make 5 external files... The vhost which is on your tutorial is what i was using and it did not work, however after a few hours working on this it works now.
All I can say is that my configuration works for me and all Wordpress sites I've set up so far.

Quote:
Originally Posted by DamianFick View Post
But for some stupid reason all of my files and folders are set as random owners such as "client0" "web1" web2" "web3" "ispconfig" "ispdb" and even "falko"
web1, web2, etc. are system usernames, client0, client1, etc. are group names. Not sure if you are reading the details your system gives you correctly.

Quote:
Originally Posted by DamianFick View Post
I dont know why but it is causing me tons of wasted time having to change the users on my websites folders. THEY WILL NOT work read/write under those user accounts. Once set to Apache once a php error ridden website is now clean as a whistle.
Did you check your error logs? If you use CentOS, did you disable SELinux?

Quote:
Originally Posted by DamianFick View Post
Another problem is postfix, i believe this is my SMTP? it wont turn on and it will not tell me why. It just says Stopping Postfix... [FAILED] Starting Postfix... [FAILED]

What port does this use if it could be that i doubt it. I am sure all ports are open.
Any errors in your mail log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote