View Single Post
  #6  
Old 5th April 2012, 10:37
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

Quote:
I tried this in the first place. But setting something in the php.ini field does surely work if you use apache_mod.
No,you mix up two fields here: for mod_php, you add the settings in the apache directives field, not the php.ini field. mod_php does not support separate php.ini files for each vhost, so you have to set the values inside the vhost file (apache directives field) as php_admin_value and php_admin_flag settings and not in a custom php.ini.

Quote:
But with FastCGI it seems there is no effect (at least in my installation).
The php.ini field is especially for fastcgi. Maybe you you did not wait until the changes were written to disk (which take at least one minute, see jobqueue in moinitor) or you entered the values as php_dmin_flag or php_admin_value instead of the normal php.ini file format.. The values of the php.ini field are written to a php.ini file in the directory /var/www/conf/web2/ and this directory is set in the fcgi strater script:

PHPRC="/var/www/conf/web2"
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote