View Single Post
  #32  
Old 4th April 2012, 01:51
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

Quote:
Originally Posted by Mitzy View Post
Here is the contents of that file.

Code:
#
# Settings for saslauthd daemon
# Please read /usr/share/doc/sasl2-bin/README.Debian for details.
#

# Should saslauthd run automatically on startup? (default: no)
START=yes

# Description of this saslauthd instance. Recommended.
# (suggestion: SASL Authentication Daemon)
DESC="SASL Authentication Daemon"

# Short name of this saslauthd instance. Strongly recommended.
# (suggestion: saslauthd)
NAME="saslauthd"

# Which authentication mechanisms should saslauthd use? (default: pam)
#
# Available options in this Debian package:
# getpwent  -- use the getpwent() library function
# kerberos5 -- use Kerberos 5
# pam       -- use PAM
# rimap     -- use a remote IMAP server
# shadow    -- use the local shadow password file
# sasldb    -- use the local sasldb database file
# ldap      -- use LDAP (configuration is in /etc/saslauthd.conf)
#
# Only one option may be used at a time. See the saslauthd man page
# for more information.
#
# Example: MECHANISMS="pam"
MECHANISMS="pam"

# Additional options for this mechanism. (default: none)
# See the saslauthd man page for information about mech-specific options.
MECH_OPTIONS=""

# How many saslauthd processes should we run? (default: 5)
# A value of 0 will fork a new process for each connection.
THREADS=5

# Other options (default: -c -m /var/run/saslauthd)
# Note: You MUST specify the -m option or saslauthd won't run!
#
# WARNING: DO NOT SPECIFY THE -d OPTION.
# The -d option will cause saslauthd to run in the foreground instead of as
# a daemon. This will PREVENT YOUR SYSTEM FROM BOOTING PROPERLY. If you wish
# to run saslauthd in debug mode, please run it by hand to be safe.
#
# See /usr/share/doc/sasl2-bin/README.Debian for Debian-specific information.
# See the saslauthd man page and the output of 'saslauthd -h' for general
# information about these options.
#
# Example for postfix users: "-c -m /var/spool/postfix/var/run/saslauthd"
OPTIONS="-c -m /var/run/saslauthd"
The last line should look as follows:

Code:
OPTIONS="-c -m /var/spool/postfix/var/run/saslauthd -r"
Restart saslauthd afterwards.

Quote:
I don't know if this is related but every time I try apt-get upgrade I get the following error, is it related?

Code:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be upgraded:
  libsasl2-2 libsasl2-dev libsasl2-modules libsasl2-modules-sql
4 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/454 kB of archives.
After this operation, 180 kB disk space will be freed.
Do you want to continue [Y/n]? y
Reading changelogs... Done
Get:1 Changelog for libsasl2-2 (http://changelogs.ubuntu.com/changelogs/pool/main/c/cyrus-sasl2/cyrus-sasl2_2.1.24~rc1.dfsg1+cvs2011-05-23-4ubuntu2/changelog) [50.6 kB]
cyrus-sasl2 (2.1.24~rc1.dfsg1+cvs2011-05-23-4ubuntu2) oneiric; urgency=low

  * Build for multiarch.  LP: #826601.

 -- Steve Langasek <steve.langasek@ubuntu.com>  Mon, 15 Aug 2011 15:30:56 -0700

cyrus-sasl2 (2.1.24~rc1.dfsg1+cvs2011-05-23-4ubuntu1) oneiric; urgency=low

  * Fix FTBFS with newer versions of Heimdal. LP: #825872

 -- Jelmer Vernooij <jelmer@debian.org>  Sat, 13 Aug 2011 18:00:52 +0200

cyrus-sasl2 (2.1.24~rc1.dfsg1+cvs2011-05-23-4) unstable; urgency=low

  * Fix yet another upstream segfault breakage in GSSAPI from CVS
    (Closes: #629589)

 -- OndĹej SurĂ˝ <ondrej@debian.org>  Wed, 08 Jun 2011 08:37:13 +0200

cyrus-sasl2 (2.1.24~rc1.dfsg1+cvs2011-05-23-3) unstable; urgency=low
:
Please use apt-pinning ( http://www.howtoforge.com/a-short-in...to-apt-pinning ) to exclude the saslauthd packages from updates.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote