View Single Post
  #1  
Old 24th March 2012, 13:49
alleks alleks is offline
Senior Member
 
Join Date: Nov 2010
Posts: 157
Thanks: 9
Thanked 9 Times in 9 Posts
Default ISPConfig not showing domain after update.php

So I go to Sites and I see all the sites as they should be, but then I try to access a domain site.com and inside the Website Panel the Domain box doesn't show anything and therefor I can't modify because it says
Quote:
Domain is empty.
Domain name invalid.
That happens after I run
Code:
php -q update.php
because I installed jailkit and read that I have to run the update sequence in order for the jailkit to work.

I can't find anything in the logs and the data exists in the database

Edit:
Firebug debuging:

Quote:
<div class="ctrlHolder">
<label for="domain">Domain</label>
<select name="domain" id="domain" class="selectInput">
<option value=''></option>
</select>
</div>
MySQL query log:

Quote:
248 Query SET NAMES utf8
248 Query SET character_set_results = 'utf8', character_set_client = 'utf8', character_set_connection = 'utf8', character_set_database = 'utf8', character_set_server = 'utf8'
248 Init DB dbispconfig
248 Query SELECT * FROM sys_session WHERE session_id = 'mdgg982jod4jti2t29j5246ul6'
120324 13:52:09 248 Query SET NAMES utf8
248 Query SET character_set_results = 'utf8', character_set_client = 'utf8', character_set_connection = 'utf8', character_set_database = 'utf8', character_set_server = 'utf8'
248 Init DB dbispconfig
248 Query SELECT client.limit_client FROM sys_user, client WHERE sys_user.userid = 1 AND sys_user.client_id = client.client_id
248 Init DB dbispconfig
248 Query SELECT * FROM web_domain WHERE domain_id = 3
248 Init DB dbispconfig
248 Query SELECT server_id,server_name FROM server WHERE mirror_server_id = 0 AND web_server = 1 AND 1 ORDER BY server_name
248 Init DB dbispconfig
248 Query SELECT domain_id,domain FROM web_domain WHERE type = 'site' AND 1 ORDER BY domain
248 Init DB dbispconfig
248 Query SELECT client.limit_client FROM sys_user, client WHERE sys_user.userid = 1 AND sys_user.client_id = client.client_id
248 Init DB dbispconfig
248 Query SELECT ip_address FROM server_ip WHERE ip_type = 'IPv4' AND server_id = 1
248 Init DB dbispconfig
248 Query SELECT ip_address FROM server_ip WHERE ip_type = 'IPv6' AND server_id = 1
248 Init DB dbispconfig
248 Query SELECT groupid, name FROM sys_group WHERE client_id > 0 ORDER BY name
248 Init DB dbispconfig
248 Query SELECT domain FROM web_domain WHERE domain_id = 3
248 Init DB dbispconfig
248 Query SELECT config FROM sys_ini WHERE sysini_id = 1
248 Init DB dbispconfig
248 Query SELECT domain FROM domain ORDER BY domain
248 Init DB dbispconfig
248 Query UPDATE sys_session SET last_updated = '2012-03-24 12:52:09' WHERE session_id = 'mdgg982jod4jti2t29j5246ul6'
248 Init DB dbispconfig
248 Query DELETE FROM sys_session WHERE last_updated < '2012-03-24 12:28:09'
I did some of the queries that had anything to do with domain and all returned correct data. What else can it be going wrong?

Last edited by alleks; 24th March 2012 at 13:59.
Reply With Quote
Sponsored Links