View Single Post
  #1  
Old 21st March 2012, 20:17
xzibiz xzibiz is offline
Junior Member
 
Join Date: Mar 2012
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default ISPConfig 3 and secondary dns problems

Hi

I have an ISPconfig3 server running web, ftp, db, email and dns.
I've tried to follow guides on howto set up an secondary dns, ns2.
I think I've done it correct.

Code:
dig @ns1.domain.net any domain.com

; <<>> DiG 9.7.3 <<>> @ns1.domain.net any domain.com
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 47636
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 5, AUTHORITY: 0, ADDITIONAL: 1

;; QUESTION SECTION:
;domain.com.                    IN      ANY

;; ANSWER SECTION:
domain.com.             3600    IN      A       91.189.XXX.XX
domain.com.             3600    IN      MX      10 mail.domain.com.
domain.com.             3600    IN      NS      ns2.domain.net.
domain.com.             3600    IN      NS      ns1.domain.net.
domain.com.             3600    IN      SOA     ns1.domain.net me.domain.net. 2012032002 7200 540 604800 86400

;; ADDITIONAL SECTION:
mail.domain.com.        3600    IN      A       91.189.XXX.XX

;; Query time: 12 msec
;; SERVER: 81.167.96.220#53(81.167.96.220)
;; WHEN: Wed Mar 21 20:01:24 2012
;; MSG SIZE  rcvd: 176
Code:
dig @ns2.domain.net any domain.com

; <<>> DiG 9.7.3 <<>> @ns2.domain.net any domain.com
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 47636
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 5, AUTHORITY: 0, ADDITIONAL: 1

;; QUESTION SECTION:
;domain.com.                    IN      ANY

;; ANSWER SECTION:
domain.com.             3600    IN      A       91.189.XXX.XX
domain.com.             3600    IN      MX      10 mail.domain.com.
domain.com.             3600    IN      NS      ns2.domain.net.
domain.com.             3600    IN      NS      ns1.domain.net.
domain.com.             3600    IN      SOA     ns1.domain.net me.domain.net. 2012032002 7200 540 604800 86400

;; ADDITIONAL SECTION:
mail.domain.com.        3600    IN      A       91.189.XXX.XX

;; Query time: 12 msec
;; SERVER: 81.167.96.220#53(81.167.96.220)
;; WHEN: Wed Mar 21 20:01:24 2012
;; MSG SIZE  rcvd: 176
So if I'm correct. It should work. Where I bought my domain.com, I've set ns1.domain.net and ns2.domain.net as nameservers.

But if I try to make a new sub-domain with ISPconfig, it goes into the database on both servers. But nothing shows if I run:
Code:
dig @ns1.domain.net any sub.domain.com
; <<>> DiG 9.7.3 <<>> @ns1.domain any sub.domain.com
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 20882
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;sub.domain.com.                 IN      ANY

;; AUTHORITY SECTION:
domain.com.             3600    IN      SOA     ns1.domain.net. me.domain.net. 2012032002 7200 540 604800 86400

;; Query time: 1 msec
;; SERVER: 91.189.123.59#53(91.189.123.59)
;; WHEN: Wed Mar 21 20:08:52 2012
;; MSG SIZE  rcvd: 94
Reply With Quote
Sponsored Links