View Single Post
Old 21st March 2012, 16:13
maxxer maxxer is offline
Join Date: May 2007
Posts: 37
Thanks: 6
Thanked 1 Time in 1 Post

no. that procedure creates the link to /etc/phpmyadmin/apache.conf, but then I believe fcgid doesn't have the permission to read from /usr/share/phpmyadmin, because when I try to access http://server/phpmyadmin I get offered the php source and not the real php web page.

Found out that in /etc/phpmyadmin/apache.conf, before <IfModule mod_php5.c> you need to add:

    Options FollowSymLinks +ExecCgi
    <IfModule mod_fcgid.c>
            AddHandler fcgid-script .php
            FCGIWrapper /var/www/php-fcgi-scripts/web1/php-fcgi-starter .php
            AllowOverride All 
            Order allow,deny
            allow from all
Reply With Quote