View Single Post
  #1  
Old 14th March 2012, 12:02
flyguy flyguy is offline
Junior Member
 
Join Date: Mar 2012
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default PHP Warning: 7 is not a valid MySQL-Link resource

OK, I've been through all the related threads I could find. The problem is that the cron list of ISPConfig does not get executed.

My error response when executing

/usr/local/ispconfig/server/server.sh

is littered with

PHP Warning: mysql_real_escape_string(): 7 is not a valid MySQL-Link resource in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 184
PHP Warning: mysql_select_db(): 7 is not a valid MySQL-Link resource in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 104

errors. I' ve checked the mysql access using

mysql -h localhost -u root dbispconfig -p

with the user(root) and password as stored in

/usr/local/ispconfig/server/lib/config.inc.php
/usr/local/ispconfig/server/lib/mysql_clientdb.conf

Ive done

cd /tmp
wget http://www.ispconfig.org/downloads/I...-stable.tar.gz
tar xvfz ISPConfig-3-stable.tar.gz
cd ispconfig3_install/install
php -q update.php

The /var/log/mysql.err and /var/mysql.log files are empty. I've had to disable the /usr/local/ispconfig/server/server.sh entry in crontab just to keep my sever from misbehaving.

I have
IServer: 109.74.195.109 (Debian Squeeze/Sid)
ISPConfig 3.0.4.3

Everything worked fine up to the point where I did general system upgrade. My /etc/hosts file looks like this:

127.0.0.1 localhost localhost.localdomain
109.74.195.109 www.subxplore.co.za

# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts

Anything that I can do next to solve this problem?
Reply With Quote
Sponsored Links