View Single Post
  #5  
Old 13th March 2012, 18:47
n0fx n0fx is offline
Member
 
Join Date: Apr 2006
Posts: 36
Thanks: 3
Thanked 0 Times in 0 Posts
Default This is a weird issue with my server http crashes

Quote:
Originally Posted by till View Post
Edit or add the .htaccess file which is in the web directory.
I tried editing the /var/www/web1/.htaccess file but it doesn't work. I also found another directory that had the .htaccess file which was /var/www/www.mywebsite.com/web/.htaccess. I edited the /var/www/web1/.htaccess file first and I found out the file in /var/www/web/www.mywebsite.com/ also got modified with the same information?

When I added the code, it doesn't forward the user to the http:// part of the website. it would not load at all, it just times out. I just commented out the modification in the /var/www/web1/.htaccess file, since it didn't work.

I'm having this weird issue, when a user tries to load the https:// portion of the site (it's not setup with SSL at all, I had the user with SSL checked under their account in ISPconfig but never setup the SSL for it, there is no certificate installed), it crashes the http:// part of the site. What I mean is that I can't load the http:// part of the site anymore, it just times out on the browser.

The only way to get it back up and running is to manually reboot the server. I tried to restart the apache service with /etc/init.d/apache restart but it doesn't fix the problem. I can ping the external dns/ip name and it responds back with a ping but just doesn't answer the normal http:// requests.

My server is configured with two network cards, one has an internal IP address and the other is directly connected on the net (external ip). When the http:// part of my site crashes/stops responding, I can still access the ISPconfig webpage and when I type in the internal ip address in the browser, it loads up the message that says that it's a shared IP address.

Does anyone know why when sometime loads the https:// part of the site, it causes my non ssl http:// to stop loading?
Reply With Quote