View Single Post
  #1  
Old 10th March 2012, 20:19
flyingaggie flyingaggie is offline
Junior Member
 
Join Date: Mar 2007
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default ISPConfig3, postfix, dovecot with allow custom login name problem...

Hey Guys,

I went through setting up the Debian cluster, following this tutorial:

http://www.howtoforge.com/installing...th-ispconfig-3

Everything is up and running, but I have an issue with the "allow custom login " with mail.

I'll preface this with the fact that I'm moving everything from a ISPconfig 2 setup to the new servers. With clients already setup with logins, etc on the old system, I'm trying to make the change as transparent as possible...hence, wanting to use the custom login names if possible.

I've checked the box for that in ISPConfig and I can log in to squirrel mail using the extra login after changing the dovecot-sql.conf to use login = '%u' instead of email = '%u'. However, if I send mail that way from any virtual hosts, it shows it comes from login_name@main.servername.com, instead of emailname@virtualserver.com. And, when I try to send mail back to the true address (emailname@virtualserver.com), it is kicked back with "unknown user".

Now, the weird part, if I either uncheck the allow custom login, or change the login to the same name as the email, everything works as it should both sending and receiving.

Is there something else I need to mod to make this work correctly. I've scoured the forums hoping someone else had this problem, but haven't found anything. Any help would be greatly appreciated. I've been driving myself nuts on this for a couple days. I'm sure it's probably something right under my nose, but I've just been looking at it took long to see.

Also, I can do http://www.somedomain.com/webmail and it won't work, but will work with the trailing / after webmail. I know I've fixed that before in years past, but can't seem to remember now.

Thanks a lot!!!!
Reply With Quote
Sponsored Links