View Single Post
  #10  
Old 9th March 2012, 04:53
Muszti Muszti is offline
Junior Member
 
Join Date: Mar 2012
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Post update

UPDATE:

now i can recieve e-mails, the mistake was that I havent filled out the relayhost in main.cf

but now I still have problems:

It says: mail loops back to myself.

Code:
Mar 9 03:37:46 muszti postfix/smtpd[17142]: connect from dsl51B7B9F9.pool.t-online.hu[81.183.185.249]
Mar 9 03:37:46 muszti postfix/smtp[17153]: warning: host mail.system.muszti.hu[81.183.185.249]:25 greeted me with my own hostname muszti
Mar 9 03:37:46 muszti postfix/smtp[17153]: warning: host mail.system.muszti.hu[81.183.185.249]:25 replied to HELO/EHLO with my own hostname muszti
Mar 9 03:37:46 muszti postfix/smtp[17153]: CF65B1F61618: to=, relay=mail.system.muszti.hu[81.183.185.249]:25, delay=0.39, delays=0.12/0.01/0.27/0, dsn=5.4.6, status=bounced (mail for system.muszti.hu loops back to myself)
Mar 9 03:37:46 muszti postfix/smtpd[17142]: disconnect from dsl51B7B9F9.pool.t-online.hu[81.183.185.249]
Mar 9 03:37:46 muszti postfix/cleanup[17146]: 4EAB91F61619: message-id=<20120309023746.4EAB91F61619@muszti>
Mar 9 03:37:46 muszti postfix/bounce[17155]: CF65B1F61618: sender non-delivery notification: 4EAB91F61619
Mar 9 03:37:46 muszti postfix/qmgr[17137]: 4EAB91F61619: from=<>, size=4361, nrcpt=1 (queue active)
Mar 9 03:37:46 muszti postfix/qmgr[17137]: CF65B1F61618: removed
Mar 9 03:37:46 muszti postfix/pipe[17156]: 4EAB91F61619: to=, relay=maildrop, delay=0.15, delays=0.07/0/0/0.08, dsn=2.0.0, status=sent (delivered via maildrop service)
Mar 9 03:37:46 muszti postfix/qmgr[17137]: 4EAB91F61619: removed
Mar 9 03:37:48 muszti imapd: Connection, ip=[::ffff:127.0.0.1]
Mar 9 03:37:48 muszti imapd: LOGIN, user=muszti@muszti.hu, ip=[::ffff:127.0.0.1], port=[37208], protocol=IMAP
Mar 9 03:37:48 muszti imapd: LOGOUT, user=muszti@muszti.hu, ip=[::ffff:127.0.0.1], headers=758, body=0, rcvd=296, sent=2381, time=0
Mar 9 03:37:55 muszti imapd: Connection, ip=[::ffff:127.0.0.1]
Mar 9 03:37:55 muszti imapd: LOGIN, user=muszti@muszti.hu, ip=[::ffff:127.0.0.1], port=[37210], protocol=IMAP
Mar 9 03:37:55 muszti imapd: LOGOUT, user=muszti@muszti.hu, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=87, sent=391, time=0
Mar 9 03:37:59 muszti imapd: Connection, ip=[::ffff:127.0.0.1]
Mar 9 03:37:59 muszti imapd: LOGIN, user=muszti@muszti.hu, ip=[::ffff:127.0.0.1], port=[37211], protocol=IMAP
Mar 9 03:37:59 muszti imapd: LOGOUT, user=muszti@muszti.hu, ip=[::ffff:127.0.0.1], headers=0, body=2160, rcvd=213, sent=4126, time=0
Mar 9 03:39:43 muszti imapd: Connection, ip=[::ffff:127.0.0.1]
Mar 9 03:39:43 muszti imapd: LOGIN, user=muszti@muszti.hu, ip=[::ffff:127.0.0.1], port=[37213], protocol=IMAP
Mar 9 03:39:43 muszti imapd: LOGOUT, user=muszti@muszti.hu, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=87, sent=391, time=0
Mar 9 03:40:01 muszti imapd: Connection, ip=[::ffff:127.0.0.1]
Mar 9 03:40:01 muszti imapd: Disconnected, ip=[::ffff:127.0.0.1], time=0

Code:
Subject:   	Undelivered Mail Returned to Sender
From:   	"Mail Delivery System" <MAILER-DAEMON@system.muszti.hu>
Date:   	Fri, March 9, 2012 3:37 am
To:   	muszti@muszti.hu
Priority:   	Normal
Options:   	View Full Header |  View Printable Version  | Download this as a file

This is the mail system at host muszti.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

                   The mail system

<muszti86@gmail.com>: mail for system.muszti.hu loops back to myself

I also have dns hosts for:
system.muszti.hu
mail.system.muszti.hu
mx record for system.muszti.hu that ponts to mail.system.muszti.hu

and

I have mail.muszti.hu
muszti.hu
mx record for muszti.hu that points to mail.muszti.hu

I created a mailuser: muszti@muszti.hu and it keeps saying that it loops back.

My main.cf looks like this:
Code:
# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = /usr/share/doc/postfix

# TLS parameters
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = muszti
alias_maps = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
alias_database = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
myorigin = /etc/mailname
mydestination = $myhostname, $mydomain, localhost.$mydomain, localhost
relayhost = system.muszti.hu
mynetworks = 127.0.0.0/8 [::1]/128
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
html_directory = /usr/share/doc/postfix/html
virtual_alias_domains = 
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, proxy:mysql:/etc/postfix/mysql-virtual_email2email.cf, hash:/var/lib/mailman/data/virtual-mailman
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_mailbox_base = /var/vmail
virtual_uid_maps = static:5000
virtual_gid_maps = static:5000
smtpd_sasl_auth_enable = yes
broken_sasl_auth_clients = yes
smtpd_sasl_authenticated_header = yes
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, reject_unauth_destination
smtpd_tls_security_level = may
transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
relay_domains = mysql:/etc/postfix/mysql-virtual_relaydomains.cf
relay_recipient_maps = mysql:/etc/postfix/mysql-virtual_relayrecipientmaps.cf
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
smtpd_sender_restrictions = check_sender_access mysql:/etc/postfix/mysql-virtual_sender.cf
smtpd_client_restrictions = check_client_access mysql:/etc/postfix/mysql-virtual_client.cf
smtpd_client_message_rate_limit = 100
maildrop_destination_concurrency_limit = 1
maildrop_destination_recipient_limit = 1
virtual_transport = maildrop
header_checks = regexp:/etc/postfix/header_checks
mime_header_checks = regexp:/etc/postfix/mime_header_checks
nested_header_checks = regexp:/etc/postfix/nested_header_checks
body_checks = regexp:/etc/postfix/body_checks
owner_request_special = no
content_filter = amavis:[127.0.0.1]:10024
receive_override_options = no_address_mappings
message_size_limit = 0
Thank you for your support
Reply With Quote