View Single Post
  #1  
Old 9th March 2012, 04:42
n0fx n0fx is offline
Member
 
Join Date: Apr 2006
Posts: 36
Thanks: 3
Thanked 0 Times in 0 Posts
Default SSL Certificate Error ssl_error_rx_record_too_long ISPconfig 2 Debian

ISPConfig: v2.2.32
Debian: 5

I currently have ISPConfig v2.2.32 installed and it's been working for 2 years. I only have one website setup that I'm using with ISPConfig and it's running debian as the base OS.

I set it up a while ago and I don't remember setting up https:// to the site. Is there any way I can check to see if https:// has been setup for the site? I tried to locate any *.crts on the disk and I did see some but it seems to be the default ones installed with ISPConfig. The server is definitely listening to port 443, when I ran netstat.

When I load the browser and point to it with the DNS or IP of the server, I get this error:

SSL received a record that exceeded the maximum permissible length.

(Error code: ssl_error_rx_record_too_long)

This is my search for *.crt with locate command:

debianbox:/etc/apache2# locate *.crt |more -l
/etc/postfix/ssl/smtpd.crt
/etc/ssl/certs/ca-certificates.crt
/home/admispconfig/ispconfig/web/phpmyadmin/libraries/auth/swekey/musbe-ca.crt
/root/ispconfig/httpd/conf/ssl.crt
/root/ispconfig/httpd/conf/ssl.crt/ca-bundle.crt
/root/ispconfig/httpd/conf/ssl.crt/ca.crt
/root/ispconfig/httpd/conf/ssl.crt/server.crt
/root/ispconfig/httpd/conf/ssl.crt/snakeoil-ca-dsa.crt
/root/ispconfig/httpd/conf/ssl.crt/snakeoil-ca-rsa.crt
/root/ispconfig/httpd/conf/ssl.crt/snakeoil-dsa.crt
/root/ispconfig/httpd/conf/ssl.crt/snakeoil-rsa.crt
/usr/share/ca-certificates/brasil.gov.br/brasil.gov.br.crt
/usr/share/ca-certificates/cacert.org/cacert.org.crt
/usr/share/ca-certificates/cacert.org/class3.crt
/usr/share/ca-certificates/cacert.org/root.crt
/usr/share/ca-certificates/debconf.org/ca.crt
/usr/share/ca-certificates/gouv.fr/cert_igca_dsa.crt
/usr/share/ca-certificates/gouv.fr/cert_igca_rsa.crt
/usr/share/ca-certificates/mozilla/ABAecom_=sub.__Am._Bankers_Assn.=_Root_CA.crt
/usr/share/ca-certificates/mozilla/AOL_Time_Warner_Root_Certification_Authority_
1.crt
/usr/share/ca-certificates/mozilla/AOL_Time_Warner_Root_Certification_Authority_
2.crt

I really don't remember if SSL was setup. I might want to setup SSL for the server but I'm not sure how to. I'm just going to buy the SSL cert from Godaddy with these instructions: http://www.howtoforge.com/forums/sho...ht=godaddy+ssl.

Any input would be appreciated, thanks.
Reply With Quote
Sponsored Links